Skip to Content
avatar image
Former Member

JDK 1.4 or JDK 1.6 for PI 7.3 - dependency on JDBC files

Hi Guys,

We have just upgraded PI from PI 7.02 to PI 7.3 and we are gettting confusing java errors from the Java side. Some of the JDBC connections to oracle databases are not working.. None of the SQL server connections are working.

My questions are ,

1. Does PI 7.3 needs JDK 1.6?.

2. If yes, i will have to upgrade the oracle / java jdbc jar files to corresponding version. is that correct?. None of the document seems to be confirming the need to have JDK upgraded to 1.6 eventhough i found couple of SDN aritcles suggesting that it should be in JDK 1.5.

3. is cryptography extenstion installed by default with PI 7.3?. My basis guys have upgraded the system with Sun Unlimited JCE policy - if we are using SAP JVM, should not we be using JCE policy from SAP?. If, yes, how do i install the SAP JCE policy file in to SAP JVM?.

Thanks for your help in advance.

Regards

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Mar 01, 2012 at 08:12 AM

    Hi,

    1) PI 7.3 needs SAPJAM 6.1 which means JDK 1.6 only so PI 7.3 need JDK 1.6.

    2) For JDBC driver refer note 1398807 & OSS note 639702

    3) For SAP JVM 6.1 download the JCE policy as following:

    http://www.oracle.com/technetwork/java/javase/downloads/index.htm

    l. Under Downloads goto to section: Java Cryptography Extension

    (JCE) Unlimited Strength Jurisdiction Policy Files 6. Click on

    Download Button

    Please refer SAP note 1240081.

    Regards,

    Vipin

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 01, 2012 at 07:36 AM

    When you use PI 7.3 the Jdbc drivers compatability jar required JDK 1.6. So, you should have JDK 1.6.

    Let some one give the input for SAP JVM policy procedures.

    Regards

    Pothana

    Add comment
    10|10000 characters needed characters exceeded