Skip to Content
0
Former Member
Feb 24, 2012 at 09:35 PM

Problem with WebService and HTTP Post action blocks

44 Views

I am trying to access a web service that I created using WCF.NET from MII. The service is hosted in IIS on a server on our company intranet. I have verified that I can use the service from a simple console application client, and that the WSDL is exposed properly.

When I try to input the WSDL url into a WebService action block in MII, it gives me back an error. I thought maybe the version of MII I am using (12.0) didn't like the WSDL format, so I tried a simple HTTP Post action block with a properly formatted SOAP document. This failed with a java exception "Unknown Host".

After this I went to the web server where the web service is located and "pinged" the MII server without a problem.

I then tried the same HTTP Post action, but used the IP address for the web server instead, and the HTTP Post action block still fails.

Any idea why my MII server cannot "see" the web server?

Thanks experts!

John