Skip to Content
author's profile photo Former Member
Former Member

Error In Web Dynpro Application

Hi All,

I'm the beginner in the Web Dynpro applications. I got the an error. Pls look into that and get me the solution.The error is

May 17, 2005 3:23:15 PM /userOut/deploy (com.sap.ide.eclipse.sdm.threading.DeployThreadManager) [Deploy Thread] ERROR:

Invitation.ear -> Deployment aborted

Reason:

Cannot determine sdm host (is empty). Please configure your engine/sdm correctly !

</b><b></b><b></b><b></b>

Add a comment
10|10000 characters needed characters exceeded

Related questions

4 Answers

  • author's profile photo Former Member
    Former Member
    Posted on May 17, 2005 at 02:05 PM

    Hi

    Go to Windows>Preferences>J2EE Engine settings and enter your Message Server Host name as "Machine Name where your WEBAS is running" and port as 36<J2EE instance number + 1> For example if your Port number is 50000 then your Message server port would be 3601.

    If it is 50100 then your Messager server port would be 3602.

    P.S : The points if awarded should be given to Santhosh :).

    Regards

    ravi

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on May 17, 2005 at 02:05 PM

    Hi,

    In your NetWeaver Developer Studio (NDS)

    1. Click Windows --> Preferences --> SAP J2EE Engine

    2. Enter the SDM host

    3. Message Server port

    Try deploying it.

    Regards,

    Santhosh.C

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on May 18, 2005 at 04:43 AM

    Hi Naidu,

    There are two possibilities.

    One is as described in above posts where you have to set your J2EE server.

    second is to check whether specified J2EE server is up and running.

    You can check this by opening J2EE engine view from Windows->show view->J2EE Engine.

    If it shows dispacher, sdm and server0 instances as green means server is up and running. otherwise start your J2EE server.

    If it works then don't forget to reward points 😉

    Regards,

    Bhavik

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on May 18, 2005 at 09:04 AM

    HI,

    Have you installed WAS 6.40, if not get it from http://service.sap.com ot http://sdn.sap.com incase it is installed is it local or remote

    you have to specify the server host in NWDS as mentioned by other posts if it is local mention local if it is remote <servername>, indicate port as 3601, new in windows show view -> j2ee enginee -> you will see

    Dispatcher

    SDM

    Server should show Green signal .. now you are ready tobuild and run applications..

    hopw this helped you

    Regards,

    RK

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.