Skip to Content
0
Former Member
May 16, 2005 at 04:23 PM

Error in webAS SR1 upgrade to SP 11

18 Views

Hi,

When updating a webAS 6.40 ABAP+Java SR1 to SP11, it fails due to an error on step 17/21 (Deploy via SDM/J2EE). The sapinst log states:

<i>MUT-02041 SDM call of deploySdaList ends with returncode 4. See output of logfile /sapinst/webas_ps11/callSdmViaSapinst.log</i>

The content of file callSdmViaSapinst.log is:

<i>(...)

05/05/16 12:51:27 - Start updating EAR file...

05/05/16 12:51:27 - start-up mode is lazy

05/05/16 12:51:27 - EAR file updated successfully for 610ms.

05/05/16 12:51:27 - Start updating...

05/05/16 12:51:28 - EAR file uploaded to server for 568ms.

05/05/16 12:51:29 - ERROR: Not updated. Deploy Service returned ERROR:

java.rmi.RemoteException: Cannot deploy application sap.com/tcTechSrvXML_DAS..

Reason: Cannot load one of the bean interfaces or the bean class of bean ArchStoreConfigBean.; nested exception is:

com.sap.engine.services.ejb.exceptions.deployment.EJBXMLParserException: Cannot load one of the bean interfaces or the bean class of bean Arc

hStoreConfigBean.

(...)

Caused by: com.sap.engine.services.ejb.exceptions.deployment.EJBXMLParserException: Cannot load one of the bean interfaces or the bean class of

bean ArchStoreConfigBean.

(...)

Caused by: java.lang.ClassNotFoundException: com.sap.archtech.daservice.ejb.ArchStoreConfig

-


Loader Info -


ClassLoader name: [sap.com/tcTechSrvXML_DAS]

(...)

Resources:

(...) /usr/sap/DXI/DVEBMGS01/j2ee/cluster/server0/apps/sap.com/tcTechSrvXML_DAS/servlet_jsp/DataArchivingService/work

/usr/sap/DXI/DVEBMGS01/j2ee/cluster/server0/apps/sap.com/tcTechSrvXML_DAS/servlet_jsp/DataArchivingService/root/WEB-INF/classes

05/05/16 12:51:29 - ***********************************************************

May 16, 2005 12:51:29... Info: End of log messages of the target system.

May 16, 2005 12:51:29... Info: ***** End of SAP J2EE Engine Deployment (J2EE Application) *****

May 16, 2005 12:51:29... Error: Aborted: development component 'tc/TechSrv/XML_DAS'/'sap.com'/'SAP AG'/'6.4011.00.0000.20050127171130.0000':

Caught exception during application deployment from SAP J2EE Engine's deploy service:

May 16, 2005 12:51:29... Info: ***** End of SAP J2EE Engine Deployment (J2EE Application) *****

May 16, 2005 12:51:29... Error: Aborted: development component 'tc/TechSrv/XML_DAS'/'sap.com'/'SAP AG'/'6.4011.00.0000.20050127171130.0000':

Caught exception during application deployment from SAP J2EE Engine's deploy service:

java.rmi.RemoteException: Cannot deploy application sap.com/tcTechSrvXML_DAS..

Reason: Cannot load one of the bean interfaces or the bean class of bean ArchStoreConfigBean.; nested exception is:

com.sap.engine.services.ejb.exceptions.deployment.EJBXMLParserException: Cannot load one of the bean interfaces or the bean class of bean ArchStoreConfigBean

.

(message ID: com.sap.sdm.serverext.servertype.inqmy.extern.EngineApplOnlineDeployerImpl.performAction(DeploymentActionTypes).REMEXC)

May 16, 2005 12:51:29... Info: J2EE Engine is in same state (online/offline) as it has been before this deployment process.

May 16, 2005 12:51:29... Info: -


Deployment was successful -


May 16, 2005 12:51:29... Info: Summarizing the deployment results:

May 16, 2005 12:51:29... Error: Admitted: /sapinst/cds/patch_webas_sp11/J2EE-RUNT-CD/J2EE-ENG/ONLINE/SAPJTECHS11_0.SCA

May 16, 2005 12:51:29... Info: Already deployed: /sapinst/cds/patch_webas_sp11/J2EE-RUNT-CD/J2EE-ENG/ONLINE/LMSERVICE11_0.SCA

May 16, 2005 12:51:29... Error: Processing error. Return code: 4</i>

Does anybody know what does this mean and how to correct it?

Thanks,

Daniel