Skip to Content
0

BO Installation in AIX - SQL Anywhere database not deployed

Dec 25, 2016 at 03:50 PM

375

avatar image

Hello Experts,

I am trying to install SAP BO BI Platform 4.2 SP03 on IBM AIX 7.1 TL4. I am selecting to install the bundled SQL Anywhere 16 database for CMS and Audit. The installation finishes with error. The log says:

Server Intelligence Agent has failed to initialize because the bootstrap file is invalid. Please restore your bootstrap file from your backup.

What I can see is:

  • The bootstrap files are empty.

  • There is no CMS and Audit database deployed. The database directory is empty.

Installation directory is: /sybase/CDO/sapdata1/BIP/

I have tried the installation in multiple times. Also tried to install SAP BO BI Platform 4.2 SP2. In all cases, I am facing same issue.

Any idea ?

Thanks and Regards,

Arijit

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

5 Answers

Best Answer
Arijit Das Jan 06, 2017 at 06:11 PM
0

We have successfully installed SAP BO BI Platform 4.2 SP3 with bundled SQL Anywhere 16 database in IBM AIX 7.1 TL4. The installation worked when we changed the installation directory to /usr/sap.

Not sure why it did not work when we selected /sybase/CXO/sapdata1 as installation directory.

Share
10 |10000 characters needed characters left characters exceeded
Denis Konovalov
Dec 28, 2016 at 06:04 PM
1

you need to look at setupengine.log file for details on why its failing.
the error you shared is AFTER whatever happened that prevented Sybase install, so it is not useful.

Show 8 Share
10 |10000 characters needed characters left characters exceeded

Hi Denis,

You are right. After looking into the setupengine.log, I can see that the CMS and Audit database creation is failed due to following error:

Cannot find the language resource file (dblgen16.res).

Detailed log:

23:02:26.446  Commandline  :  . /sybase/CXO/sapdata1/BIP/sqlanywhere/bin64/sa_config.sh; /sybase/CXO/sapdata1/BIP/sqlanywhere/bin64/dbinit -dba dba,******** -p 8192 -z UTF8BIN -zn UTF8BIN "/sybase/CXO/sapdata1/BIP/sqlanywhere/database/BI4_CMS.db"
23:02:26.448 === BEGIN: . /sybase/CXO/sapdata1/BIP/sqlanywhere/bin64/sa_config.sh; /sybase/CXO/sapdata1/BIP/sqlanywhere/bin64/dbinit -dba dba,******** -p 8192 -z UTF8BIN -zn UTF8BIN "/sybase/CXO/sapdata1/BIP/sqlanywhere/database/BI4_CMS.db" 2>&1
23:02:26.448 Working directory: /sybase/CXO/sapdata1/BIP/InstallData/logs/2016.12.28.22.23.47
23:02:26.579 Cannot find the language resource file (dblgen16.res).

I can see that the dblgen16.res file is present in the /sybase/CXO/sapdata1/BIP/sqlanywhere/res folder.

Is it some kind of bug in the installer ?

Thanks,

Arijit

0

how did you extracted the installer first ?
also, check that you applied chmod 755 to the whole of the install media after extraction.

what are your ulimits ?

this is very basic installer functionality, I'm fairly sure there is no bug - its something environmental.

0
  • I extracted the files(part 1 & 2) using winrar in a windows system and then copied to the AIX system with winscp.
  • I have applied 777 to the whole installer directory and sub-directories.
  • ulimit has been set to unlimited.

Still facing the same issue. This is occurring in multiple similar aix systems (dev/prod) and with different installers (4.2 SP 2 & 3).

0

you can't unzip unix installers on windows and then move them to Linux/Unix systems.
you need to use unrar on AIX to extract it. then install will work.
Download page for unix/linux should have a note explaining this.

1

Thank you Denis. I'll try the way you suggested and update the thread.

0

Hi Denis,

I have extracted the installer files using unrar in the AIX box itself as suggested in the note and then started the installation. But the same issue is still occurring.

Can this be related to the user I am using for installation ? I have created the user as :

mkuser -a <username>

and then set the password with:

passwd <username>

LANG and LC_ALL have been set to EN_US.UTF-8

Anything I am missing ?

Regards,

Arijit

locale.png (5.8 kB)
0

the Unix installation guide lists all pre-requisites for the user/environment variables and other settings.
make sure the locale that is installed is in fact EN_US.UTF-8 and not en_us.utf-8.
If all checks out - this might be a time to open a support Incident with SAP for detailed investigation.

0
Show more comments
Arijit Das Dec 25, 2016 at 03:58 PM
0

Screenshots added


capture2.png (4.7 kB)
capture1.png (40.8 kB)
Share
10 |10000 characters needed characters left characters exceeded
Manikandan Elumalai Dec 26, 2016 at 05:50 PM
0

Hi Arijit,

Did we checked the PAM for the supportability?

Thanks

Mani


capture.png (68.7 kB)
Share
10 |10000 characters needed characters left characters exceeded
Arijit Das Dec 27, 2016 at 04:43 PM
0

As per PAM, AIX 7.1 is supported. I understand it is not tested with TL4, but need some confirmation if anyone else has faced similar issue.

Share
10 |10000 characters needed characters left characters exceeded