Skip to Content
3
Former Member
Feb 09, 2012 at 09:44 AM

Problem with IUMPrincipal dependency when trying to create an ACLEntry

36 Views

Hi Experts,

I'm trying to create a new ACLEntry using 7.30. My code is :

IResource resource = ResourceFactory.getInstance().getResource(originalRidFile, context);

ISecurityManager securityManager = resource.getRepositoryManager().getSecurityManager(resource);

IResourceAclManager acmManager = ((IAclSecurityManager)securityManager).getAclManager();

IAclPermission permission = getPermission();

IPrincipal principal = getPrincipalUME();

acmManager.createAclEntry((IUMPrincipal)principal, false, permission, 0);

But here I need to set a dependeny to my development component to another component which contains IUMPrincipal. I tried without casting acmManager.createAclEntry(principal, false, permission, 0); but an error occured that this code is referencing to IUMPrincipal: "The type com.sapportals.portal.security.usermanagement.IUMPrincipal cannot be resolved. It is indirectly referenced from required .class files"

I tried to add com.sap.portal.usermanagement as dependency but it can not be done because "grand list does not allow references". Which is the right component in the development infrastructure that should be added as a new dependency.

Edited by: Teodor Tanev on Feb 9, 2012 10:44 AM

Edited by: Teodor Tanev on Feb 9, 2012 10:49 AM