Skip to Content
avatar image
Former Member

Crystal Report on web server not displaying

Hi

I posted a problem up earlier today and thought I had solved the problem. I am getting the same problem on our clients test enviroment now.

Dev environment: VS 2010 - CR for VS 2010 - Windows 7 - Various browsers

Client Test Environment: DotnetFX4.0 runtime - CR runtime 32bit - Windows Server 2003 - IE7 or Chrome

I have copied the aspnet_client folder and it's contents to the root folder that the web app lives in (and various other places to try and get it to work)

I have given 'Everone' access to the C:\Windows\Temp' folder - I can see crystal temp files created there.

I've tried installing Chrome but this gives the same problem.

I have overcome the log4net.dll/type initializer/report failed to load errors and now have the last hurdle.

The report simply is not there. The page appears in the browser, and I can see a button that I have placed there on the page. I am logging the progress through the code to a text file and it all seems fine. The report is simply not there.

When this happened on our test server here, putting the aspnet_client folder in the right place did the trick and it worked. I'm guessing that the problem is related to this, and that the CR viewer simply does not have access to it or something, or it's in the wrong place.

Can anyone shed any light on this. I'm on day 3 of getting Crystal working on servers and it's wearing me down.... 😔

Julian

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Feb 10, 2012 at 09:51 PM

    See if an HTTP sniffing utility such as [Charles|http://xk72.com/] or [Fiddler|http://www.fiddlertool.com/fiddler/] will tell you where the process is looking for the viewer directory.

    - Ludek

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Chris,

      I posted this problem again, and got it sorted. Don't know if it will help you?

      Have a look through the following post.

      Julian

  • avatar image
    Former Member
    Feb 15, 2012 at 09:33 AM

    Thanks guys, I think there's a couple of things there that I haven't tried yet.

    Will let you know if I get things working!

    Julian

    Add comment
    10|10000 characters needed characters exceeded