Skip to Content
avatar image
Former Member

Applets not working in Java version 1.6 update 29

Hi,

We are using MII 12.0.2 in Java 1.4.07 server.

In users PC, currently java version are upgraded to Java 1.6 update 29. Till date applets are worked in earlier versions like update 26. But currently no applet is working. It is showing error as

load: class iGrid not found.

java.lang.ClassNotFoundException: iGrid

at sun.plugin2.applet.Applet2ClassLoader.findClass(Unknown Source)

at sun.plugin2.applet.Plugin2ClassLoader.loadClass0(Unknown Source)

at sun.plugin2.applet.Plugin2ClassLoader.loadClass(Unknown Source)

at sun.plugin2.applet.Plugin2ClassLoader.loadClass(Unknown Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

at sun.plugin2.applet.Plugin2ClassLoader.loadCode(Unknown Source)

at sun.plugin2.applet.Plugin2Manager.createApplet(Unknown Source)

at sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Unknown Source)

at java.lang.Thread.run(Unknown Source)

Exception: java.lang.ClassNotFoundException: iGrid

Error is showing for all applet types like iCommand, iBrowser etc.,

If we downgrad the Java version , it is working.

How to solve this problem? is this type of problem (Java related) solved in MII 12.1 or 12.2 versions?

Regrads,

Senthil

Edited by: senthil kumar on Feb 7, 2012 9:06 AM

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    avatar image
    Former Member
    Feb 07, 2012 at 08:25 AM

    Hi Senthil,

    The problem is because of java version update 29.

    Check SAP Note [1649526|https://service.sap.com/sap/support/notes/1649526]

    Which suggests 2 options:

    1. Rollback to a version previous of the JRE less than 1.6.0_29

    2.Update the java policy

    In the java.policy file, add the following line:

    permission com.sun.deploy.security.SecureCookiePermission "*.some.site.com:80-", "listen,accept,connect,resolve";

    Where "*.some.site.com:80" is the domain that applets are running in and the port is the server port of the webserver.

    Add this inside the section that starts with:

    // default permissions granted to all domains

    grant {

    // other existing permissions

    // Add the line above here

    };

    The file you can find under the folder "../Java/JRE6/lib/security".

    Regards

    Anshul

    Add comment
    10|10000 characters needed characters exceeded