Skip to Content
avatar image
Former Member

SAP Production Systems Database backup failed

Dear Guru,

I have been facing a problem with our SAP Production system's oracle database backup for last three days. Our back up goes through TSM server. At night 10 pm we have schedule backup for whole offline + redo log backup, 11 pm check and update optimizer statistic and at 11:30 pm Check Database. For last three days above mentioned backup getting failed and we are not able to get such a details log by which i can understand the issue. But Our Development server and Quality server's backup which are scheduled at 12 am and 2 am, the both backup schedules finish successfully. And in morning all schedule backups of Production systems finish without any errors. The issues is coming only with Whole database backup + redo log Backup which schedule at night 10 pm. I have mentioned the log whatever i have got in below:

07.02.2012 07:30:06 Job started

07.02.2012 07:30:06 Job has exceeded its latest start date

07.02.2012 07:30:06 Job cancelled after system exception ERROR_MESSAGE

Above mentioned logs are showing 1day advance log where i have mentioned yesterdays log. That means it should shows 06.02.2012 instead of 07.02.2012 and time should be 22:00:00 instead of 07:20:06.

Our Oracle version is 10.2.0.4.0/ kernel release 701/BRBACKUP 7.00 (40)

Please Guide me.

Regards,

Samrat Chakraborty

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Best Answer
    Feb 08, 2012 at 06:02 PM

    OK,

    this has nothing to do with brbackup or TSM.

    You batchjob starts at 07:30 !!!

    Means before that, you do not have any action at all.

    Then the job crosschecks it has passed its intended startdate and terminates,

    which is correct, since you do not like brbackup to shut down your DB at 07:30!

    No brbackup is started at all, which is why you get no log and no tsm connect takes place.

    I assume, you misconfigured some operationmodes and at 07:30 an OP-modeconfiguration

    with batchjobs switches back in place so that the jobs do start too late.

    Check RZ04 and the OP mode timetable

    If it is not this, it has to be something else with the batch scheduler causing delay

    or may be all BTC processes are busy, but this seems unlikely with a start at 07:30 sharp..

    Volker

    Add comment
    10|10000 characters needed characters exceeded

  • Feb 07, 2012 at 05:47 AM

    Hi,

    I think you should be getting logs in TSM side which can give you exact reason, so contact yout tivoli team for their logs. My guess is that for that particular time span media is not getting available for backup.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 07, 2012 at 06:13 AM

    Dear Samrat,

    Try to check the parameter "expir_period" in init<SID>.sap .make it 0 and try.

    I hope it helps...

    experts....correct me if i am wrong.

    Thanks,

    Veeresh K R

    Add comment
    10|10000 characters needed characters exceeded

  • Feb 07, 2012 at 06:40 AM

    hi,

    first of all, you have to upgrade your BRTOOL because your brtools is 700(40) and kernel is 701.

    2nd.. send detail log.

    Regards,

    Add comment
    10|10000 characters needed characters exceeded