Skip to Content
author's profile photo Former Member
Former Member

Call transformation

Hi Guru's,

When i tried to convert table entries to xstring using the below code got an error XML_CONVERSION_NO_NUMBER.

CALL TRANSFORMATION id_indent

SOURCE itab = <fs1>

RESULT XML lv_xstring2.

when i tried to convert the below table entry it is getting converted without any error

component name type length content

mandt C 3 005

object C 1

flagn C 30 dum

seq N 2 01

value C 40 dum

seq2 N 1 0

form C 30

prog C 40

par C 30

but it is throwing error for the below entry.

mandt C 3 005

flagn C 30 dum

seq N 2 01

pri N 2

filed_key C 40

kindly help me to solve this issue.

Edited by: vadiv_maha on Feb 6, 2012 12:48 PM

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • Best Answer
    Posted on Feb 06, 2012 at 03:56 PM

    Hello Vadiv,

    have you checked, wether the "pri"-field ist filled correctly with "00" or is it >INITIAL< - e.g. empty -?

    If you specify such a field with numc-Type, you should provide the correct value for initial.

    Kind regards,

    Hendrik

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.