Skip to Content
author's profile photo Former Member
Former Member

Trouble accessing - KM content

Hello All,

Currently we are have a trouble accessing the KM contents , We are getting the following error

RuntimeException: InitialConfigException: Configuration framework system error : "A problem during initialization of the configuration Framework has been detected . Possible reason can be failure discovering of the sources."

Could anyone please let me know the cause of the problem. And the possible resolution for the same .

Regards,

Ronniee.

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Feb 06, 2012 at 12:48 AM

    Hello All,

    To add more content to the above scenario , I am unable to access the Content Administration --> KM Content, Unable to access the repository (Using Repository Monitor), The Index Management Service Is also not active.

    Could anyone please suggest the possible cause , and the resolution for the same.

    Regards,

    Ronniee.

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hello All,

      The resolution for the problem is as follows :

      The initial problem was , We were not able to View KMC iViews (providing a Runtime Exception)

      java.lang.RuntimeException: InitialConfigException: Configuration framework system error: "A Problem during initialization of the Configuration Framework has been detected. Possible reason can be failure during discovering of the sources."

      The cause of the actual problem was - The Write-protect Mode for the PCD was activated , due to which the config framework cannot start thus preventing the entire KMC from starting up.

      Please perform the following steps :

      1: Start the Visual Administrator.

      2: Navigate to Global Configuration -> Server -> Services -> com.sap.portal.pcd.gl.

      3: If Pcd.Pl.WriteProtectActivated is set to 'True', click the Reset Default Global Properties icon.

      4: This property should now be restored to it's default value (False).

      5: Save changes.

      6: Restart the J2EE engine.

      Regards,

      Ronniee.

  • author's profile photo Former Member
    Former Member
    Posted on Feb 06, 2012 at 09:24 AM

    The resolution steps being found

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.