Skip to Content
author's profile photo Former Member
Former Member

Bank account number not valid in XK02

Hi,

I get a error bank account number not valid.

Country Netherland (NL)

IBAN - NL30CITI0105623879

SAP propose bank account as - 0105623879. But system shows error that "Invalid bank account number".

Debugging shows Bank account number is not valid.

Checked in many sites, it shows that IBAN is correct. But when generation back to account number, SAP says it is wrong.

Your suggestion is hightly appreciated.

John

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

5 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Feb 06, 2012 at 11:19 AM

    Hi,

    SAP defines some set as error, if your requirement is different you can change them to warnings and proceed.

    Goto T-code: OBA5 for work area:AR change the message from error to warning.

    Regards,

    G K

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Feb 07, 2012 at 05:47 AM

    Dear expert

    Refer oss notes

    507186,

    144764,

    310988

    572022

    920427

    857036

    Regards

    Ajeesh.s

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Feb 06, 2012 at 05:06 AM

    Hi John,

    Check the country specfic setting in

    SPRO> SAP NetWeaver> General Settings > Set Countries> Set Country-Specific Checks

    Go to NL, and untick the Bank data in Further checks

    SKS

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Feb 06, 2012 at 05:26 AM

    Hi,

    Go to Transaction OY17, deselect the 'Bank data' field and save

    Thanks,

    Raviteja

    Add a comment
    10|10000 characters needed characters exceeded

    • Hi,

      Please refer SAP note 1333154 - IBAN NL: Account number not valid

      Solution

      The standard solution is to deactivate the validity check for Netherlands, or to customize the message type of the message AR 124, so that for instance a warning will appear instead of an error.

      If you still want to have the validity check active and get a warning only for invalid or "invalid" Dutch account numbers (the message type customising is unfortunately not country dependent), activate the user-exit 002 in program SAPLSSRV (function EXIT_SAPLSSRV_002).

      Then apply the attached correction. The include ZXF10U02 will then contain program code with the following functionality:

      In case of a dutch account number handle the message AR124 as a warning.

      Regards

      SM

      Edited by: shanumonu on Feb 6, 2012 6:47 AM

  • author's profile photo Former Member
    Former Member
    Posted on Feb 06, 2012 at 05:55 AM

    Hi Expert,

    To solve the issue as soon as possible, just provide the Error Message Number and all the error details, which may give us an idea to recover the issue.

    Regards,

    GK

    SAP

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.