Skip to Content
0
Former Member
Feb 05, 2012 at 01:45 PM

SAP on Ubuntu > Correct settings for etc/hosts?

117 Views

Hi,

I installed the SAP test drive version on Ubuntu (VirtualBox). After starting the SAP GUI (

/home/minisap/SAPClients/SAPGUI7.20rev5/bin/guistart /H/ubuntu64/S/3242

) I get the following error:

Error: partner 'ubuntu64:3242' not reached
Sun Feb  5 14:07:26 2012
Release 720
Component NI (network interface), version 40
rc = -10, module nixxi.cpp, line 3286
Detail NiPConnect2: 127.0.0.1:3242
System Call connect
Error No 111
'Connection refused'

I guess that the settings of the file etc/hosts are not correct. After the installation of ubuntu the file contains

10.0.2.15    ubuntu64    # Added by NetworkManager
127.0.0.1    localhost.localdomain    localhost
::1    ubuntu64    localhost6.localdomain6    localhost6
127.0.1.1    ubuntu64
# The following lines are desirable for IPv6 capable hosts
::1     localhost ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts

According to the test drive readme file I have to ensure that etc/hosts contain at least the following lines:

127.0.0.1 	localhost 	
n.n.n.n 	<HOSTNAME>.<DOMAINNAME> 	<HOSTNAME>
n.n.n.n 	nplhost 	
where "n.n.n.n" is a valid IP-adress.

I tried different settings but the above mentioned error still occurs... Does anyone know the correct settings of etc/hosts or know what the problem could be?

Thanks and regards