Skip to Content
author's profile photo Former Member
Former Member

Dtp error in process chain

Hi All,

In my process chain while loading data to dso using dtp iam getting the following error

Error 'Maßeinheit EA ist in Sprache DE nicht angelegt ' at conversion exit CONVERSION_EXIT_CUNIT_INPUT (field SALES_UNIT record RSDS

when iam executing it manually it is getting successful,is there any permanent solution to run the dtp without errors during the trigger of process chains?



Add a comment
10|10000 characters needed characters exceeded

Related questions

4 Answers

  • Posted on Feb 04, 2012 at 05:18 AM

    Hi VR

    English translation of this would be " EA unit is not created in language DE"

    Check this table T006A if you have an entry maintained for EA in Language DE ( German)


    D EA EA EA each each

    You can try to transfer global setting from RSA1 ->Source System >Right Click -

    >Transfer Global Settings

    Check this link as well Error: CONVERSION_EXIT_CUNIT_INPUT and 0Unit



    Edited by: Anindya Bose on Feb 4, 2012 10:49 AM

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Feb 04, 2012 at 05:52 PM


    Just try few more things in case suggestions given anindya doesnt work out:

    It seems that value is not in context to the logon language.As this exit reads from T006A table and the logon language from SPRAS and the loaded value from MSEH3. If there is no entry there for the logon language, an error occurs in the conversion exit.

    You can maintain entries in this table in the Customizing:

    goto T-code SPRO->SAP reference IMG->BW Customizing Implementation Guide->General Settings ->Measurement units. Select the measurement units here using the relevant button.

    hope it helps



    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Feb 04, 2012 at 10:28 PM

    As u said manual DTP execution is getting successful, and issue is when this DTP executes in process chain. See whether the following works.

    In RSPC open the PC and from menu . Process Chain --> Attributes --> Execution User. If its 'BW Background User', change it to 'Current User' and execute.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Feb 05, 2012 at 10:06 AM


    Looks like for DE language unit is not maintained in R/3 side..first maintain same in R/3 and then get it replicated in BW through transfer global setting mode..

    refer to following thread as well

    Problem in Conversion Exit.

    CONVERSION_EXIT_CUNIT_INPUT error in flat file load

    when u are doing manually there is a possibility u are running through EN language hence it is getting successful..

    Thanks and regards


    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.