Skip to Content
author's profile photo Former Member
Former Member

ME_GUI_PO_CUST / ME_PROCESS_PO_CUST

Hi Experts,

I have implemented both BADIs and its working fine on item level for one item. I can save the right things to the database.

But when I try to insert more than one item, the values are not transferred correct to the dynpor and into the database. Do I need any internal table or is there a method to get the correct result?

Has anybody an idea how I can solve this issue?

And why is it not possible to mark a field as mandatory? I set the fieldstatus = '+' in ME_PROCESS_PO_CUST~FIELDSELECTION_ITEM, but is not mandatory and there is no error message.

Thank you in advance.

Best regards,

Marc

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • Posted on Feb 02, 2012 at 09:43 AM

    Did you pass the meta field correctly as in example available in class CL_EXM_IM_ME_PROCESS_PO_CUST. The metafields are available in type group MMMFD.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.