Skip to Content
avatar image
Former Member

Sybase ASE & BODS connectivity issue

Datastore creation give server not found error with Sybase ASE.

Unable to create a data store when use Sybase ASE database Tried different combination of DB Server name like server name, server name + port number, IP, & IP + port number. It giving me same error all the time..

Tested connection is ODBC it work fine but same config from same server it gives me following error....

Can you help us my your valuable comment on this issue..

WARNING: Cannot establish database connection.

'Sybase connection error: <Sybase CS Library message number

<101188867> Serevity <5>: Message Text is ct_connect():

directory service layer: internal directory control layer error:

Requested server name not found>' <BODI-1111341)

Do you want to save this datastore anyway?

Thanks

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

3 Answers

  • Best Answer
    Mar 17, 2015 at 03:27 AM

    Hi Kumar,

    Please refer the below KBA regarding your issue.

    1529986 - How to configure Sybase to be able to create a datastore - Data Services

    https://service.sap.com/sap/support/notes/1529986

    Thanks,

    Daya

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 02, 2012 at 03:23 AM

    The following is the result of quite a bit of trial-and-error on a contract in Miami a couple of months ago.

    If you don't already have it, you need to obtain and install Sybase's "PC Client," aka "Adaptive Server Enterprise PC Client". In my case, I used ver. 15.7. This software gets installed on the DS job servers. You may want it on your local workstation, too, to be able to roam around in the ASE's data.

    In Data Services, I assume you've created a datastore using DS's native ASE driver. (I.e., don't use ODBC.)

    Find and run the "Open Client Directory Service Editor," one of a slew of gizmos which comes w/ the PC Client.

    Pick "Interfaces Driver" (likely the only thing you can pick). You'll get a blank, intimidating-looking "DSEDIT1" window.

    Right-click in the "Server" pane on the left and select "Add...".

    For the "Server Name," I think it's likely safest & sanest to just use the host name of the server, and suggest you use that.

    Then, you'll have the server you added, on the left, and a grid of attribute-and-value pairs on the right. Modify the Server Address, and you'll get a "Network Address Attribute" window. Click "Add". Select "TCP" as the protocol, and enter the address in the format "hostname, port", as in this example:

    asehost1.somecompany.com, 10100

    ASE listens on port 10100 by default, I think, but your system may be elsewhere. For me, the DS datastore then worked just fine.

    Good luck!

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi

      I am facing the same issue while executing the job. Has anyone got a solution? The problem exists even after configuring ASE server in Open Client Directory Service Editor.

      Thanks

      Balaram

  • May 05, 2014 at 10:37 AM

    Hi,

    I'm facing the same error,

    did you find out any solution?

    thank you

    Adriano

    Add comment
    10|10000 characters needed characters exceeded