Skip to Content
0

How to Remove extra columns of Target in Flowgarphs?

Dec 23, 2016 at 10:57 AM

59

avatar image

Hi,

We have a scenario where we have 2 columns in Source Table and 5 columns in Target Table. I can easily map the 2 columns from the source to target but the extra 3 columns are empty. Now, the problem is I don't wish to put any value in target but the flowgraphs gives validation error that the node cannot have unmapped column.

Can someone please suggest on how we can remove or stop the unmapped columns from getting updated in the target?

Regards,

Kiran Shenvi

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
Timo Wagner
Dec 24, 2016 at 12:56 AM
0

Hi Kiran,

I tried to reproduce your problem, but for me the following scenario works. Please let me know if I missed a step.

1) Source has 2 Columns (Name, Age), Target has 4 Columns (Name, Age, AdditionalField1 & AdditionalField2), Filter/Projection in Between

2) Connect it all and make sure that name and age are mapped in the Datasink.

Activation works fine. I remember that a few versions back we had an issue with the automap not being triggered. Can you please send the complete activation error and maybe also a screenshot of the mapping of your TargetTable?

Leaving some attributes unmapped can result in execution errors if those attributes are not nullable.

Best Regards,

Timo Wagner


targetmapping.png (31.8 kB)
Share
10 |10000 characters needed characters left characters exceeded
Kiran Shenvi Dec 26, 2016 at 02:47 PM
0

diasbled-remove-button.pngHi Timo,

Thanks once again. I guess you are creating flowgraphs using Web IDE.

However, I am using it via Hana Studio (version 2..16 sps9).

I reach the mapping window and select the extra field of target but still the 'Remove' Button is disabled. (screenshot attached) I am not sure if it is a bug.

But accidentally we found a workaround that selecting the column and pressing the 'Del' key from keyboard removed the column.

Strange behavior with GUI.

Regards,

Kiran


Share
10 |10000 characters needed characters left characters exceeded