Skip to Content
author's profile photo Former Member
Former Member

Additional field 'Quantity_specified' appearing on sharepoint

Hi all,

We have developed a service interface (Managepurchaserequisition)(Multiple Line Items) in ESR with 5 operations Query,Read,Create,Update and Delete.We generated the proxy in Duet Server and created the SCL business object,BSO and Mapper Classes and generated the WSDL and End Point URL's using SOAMANAGER.But when we expose the URL's in Sharepoint to create the External Content type and External list, the Read operation is showing the Extra field 'QUANTITY_SPECIFIED' along with the field 'Quantity' but we used only 'QUANTITY' field while creating the Service Interface.When i test the Service Interface from Duet Server all operations are working fine ,But in Sharepoint all other operations are working (if we made the QUANTITY_SPECIFIED field as disable in Sharepoint while creating the External Content type)except 'CREATE' operation.And we are maintaining the same structure for QUERY,READ and CREATE operation.

Can you guys please suggest me from where this 'QUANTITY_SPECIFIED' field is coming to Share point and what all we need to do to overcome from this issue.

Answers will get the reward points .

Thanks,

Harish

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

1 Answer

  • author's profile photo Former Member
    Former Member
    Posted on Feb 01, 2012 at 10:25 PM

    Hi Harish,

    I suspect that you modeled the Quantity as an optional parameter in ESR (cardinality 0..1). This could explain the additional Quantity_Specified parameter in SP.

    Can you please provide more information on your data type in ESR? Any chance to change the cardinality to 1 - making it a mandatory field?

    Cheers, Alex

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      I will make the field as mandatory and in header level i will pass zero and

      any how we are not using this field inside the program and i pass the value to this field in the Item level.

      Thanks for your valuable replies Alex.

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.