Skip to Content
author's profile photo Former Member
Former Member

Locks not getting released.

Hi,

we have set following properties in Entrprise Portal system defnition

connector properties-

Web AS Host Name - GOATLVSAP31QA.kworld.kpmg.com:8111

ITS Host Name - GOATLVSAP31QA.kworld.kpmg.com:8111

Our message server is installed in this host - GOATLVSAP31QA. This is a

HA system with two app servers - goatlapp174qa, goatl1app75qa.

Load balancing is happening in the system as expected but the session

termination is not happening when the user clicks refresh or reload the

same application. DUe to this unterminated seesions , employeee

documents are getting locked with a single session.

Request you to please help in this regard.

- Ankit

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Jan 31, 2012 at 10:57 PM

    Ankit,

    User suppose to logout from the session for the locks or session to terminate. In an Ideal scenario, when the user refresh the screen, the user expects the data to be on the screen.

    Request the user to logout and check the lock monitor.

    Thanks,

    Arjun

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Feb 01, 2012 at 12:18 AM

    Hi Arjun,

    Actually when we maintain app server parameters in connector properties in portal, this issue doesn't arises, but we have to maintain our virtual host in connector properties so that proper load balancing occurs in the system for http requests.

    This issue is occuring when I open a document and again open the same document ( it will give error that requested document is locked by user). Now when I close all the documents all locks should be released. But when I open again same document, it is giving me error that requested document is locked by the user.

    I can also see in the backend locks that they are not getting released when I close any session. When I reopen it, it gives me error that this is locked.

    Are there any particular parameter value that will solve this issue.

    Request you to please help in this regard.

    Ankit

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Feb 03, 2012 at 09:36 PM

    Since your load balancing is happening using a Message Server . Can you check the values of these parameters in the backend system and try to tweak them . Let me know in case of any questions

    ms/http_timeout

    ms/conn_timeout

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.