Skip to Content
avatar image
Former Member

Error in NW 7 ehp2 HA installation in win 2008 R2 /MSSQL

Hi Gurus,

I am facing below error during first mscs installation. I am running sapinst using virtual host.

From sapinst log -

TRACE 2012-01-28 01:25:53.693

ClusterGroup(isting status for resource 'L':)

TRACE 2012-01-28 01:25:53.693

ClusterGroup(isting status for resource 'L':).isExisting()

TRACE 2012-01-28 01:25:53.693

ClusterMgt.hostIsClustered()

TRACE 2012-01-28 01:25:53.703

State of service 'ClusSvc' on host '' is SERVICE_RUNNING

TRACE 2012-01-28 01:25:53.703

ClusterMgt.hostIsClustered() done: true

TRACE 2012-01-28 01:25:53.704

ClusterMgt._callClusterExe([group, isting status for resource 'L':], [0, 5013], [osmod.cluster.checkGroup, isting status for resource 'L':], true)

INFO 2012-01-28 01:25:53.745

CJSlibModule::writeInfo_impl()

Node cluster.exe.log already exists.

TRACE 2012-01-28 01:25:53.753 [synxcchapp.cpp:264]

CSyChildApplicationImpl::doStart() lib=syslib module=syslib

Going to call CreateProcess/CreateProcessAsUser for 'cluster.exe' now.

TRACE 2012-01-28 01:25:53.754 [synxcchapp.cpp:560]

CSyChildApplicationImpl::doStart() lib=syslib module=syslib

Trying to start cluster.exe using CreateProcess(NULL, <command line for executable cluster.exe, NULL, NULL, TRUE, 0x420, NULL, NULL, &StartupInfo, &ProcessInfo)

TRACE 2012-01-28 01:25:53.758 [synxcchapp.cpp:638]

CSyChildApplicationImpl::doStart() lib=syslib module=syslib

A child process has been started. Pid = 19388. Executable name: cluster.exe

INFO 2012-01-28 01:25:53.763

CJSlibModule::writeInfo_impl()

Output of cluster.exe group "isting status for resource 'L':" is written to the logfile cluster.exe.log.

TRACE 2012-01-28 01:25:53.827 [synxcpipe.cpp:200]

CSyStdOutErrPipe::onUnderflow(void * buf, int maxBytes, int timeout)

lib=syslib module=syslib

Syslib info about system call. OS message 109 (The pipe has been ended.

) after execution of system call 'ReadFile' with parameter ((read end of child process output pipe)), line (403) in file (synxcpipe.cpp).

WARNING 2012-01-28 01:25:53.842

CJSlibModule::writeWarning_impl()

Execution of the command "cluster.exe group "isting status for resource 'L':"" finished with return code 5013. Output:

Listing status for resource group 'isting status for resource 'L':':

Group Node Status

-


-


-


System error 5013 has occurred (0x00001395).

The cluster group could not be found.

TRACE 2012-01-28 01:25:53.847

ClusterMgt._callClusterExe() finished action: Check for existence of cluster group 'isting status for resource 'L':'. rc: 5013, errorText: The cluster group could not be found.

TRACE 2012-01-28 01:25:53.848

ClusterGroup(isting status for resource 'L':).isExisting() done: false

TRACE 2012-01-28 01:25:53.848

Function setMessageIdOfExceptionMessage: osmod.cluster.clusterGroupNotExisting

ERROR 2012-01-28 01:25:53.848

CJSlibModule::writeError_impl()

MOS-01259 Cluster group isting status for resource 'L': does not exist.

TRACE 2012-01-28 01:25:53.854 [iaxxejsbas.hpp:488]

EJS_Base::dispatchFunctionCall()

JS Callback has thrown unknown exception. Rethrowing.

ERROR 2012-01-28 01:25:55.475 [sixxcstepexecute.cpp:988]

FCO-00011 The step collectSharedDrives with step key |NW_FirstClusterNode_Java|ind|ind|ind|ind|0|0|NW_FirstClusterNode|ind|ind|ind|ind|0|0|NW_GetSidFromCluster|ind|ind|ind|ind|1|0|collectSharedDrives was executed with status ERROR ( Last error reported by the step :Cluster group isting status for resource 'L': does not exist.)

Please help me to resolve this error.

Regards,

Ankit

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

7 Answers

  • avatar image
    Former Member
    Jan 28, 2012 at 01:08 AM

    Ankit,

    The error message says that The cluster group could not be found. Cluster group isting status for resource 'L': does not exist. Open the FailOver Cluster Management in the server and check whether SAP<SID> group has been created and has drive L. if not create the group and add the drive and try again.

    hope above helps

    Thanks,

    Arjun

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 28, 2012 at 01:30 AM

    Hi,

    SAP<SID> service should be created by the installer itself. L: is the drive where Data files will be installed- it is not a SAPMNT drive.

    Also, I have tried after creating SAP<SID> service in cluster management but still I am getting same error.

    -

    Ankit

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 28, 2012 at 04:33 AM

    sapinst log -

    Execution of the command "cluster.exe group "isting status for

    resource 'L':"" finished with return code 5013. Output:

    Listing status for resource group 'isting status for resource 'L':':

    Group Node Status

    ________________________________________

    -


    ________________________________________

    System error 5013 has occurred (0x00001395).

    The cluster group could not be found.

    TRACE 2012-01-28 01:25:53.847

    ClusterMgt._callClusterExe() finished action: Check for existence of

    cluster group 'isting status for resource 'L':'. rc: 5013, errorText:

    The cluster group could not be found.

    RROR 2012-01-28 01:25:55.475 sixxcstepexecute.cpp:988

    FCO-00011 The step collectSharedDrives with step key

    |NW_FirstClusterNode_Java|ind|ind|ind|ind|0|0|NW_FirstClusterNode|ind|ind|ind|ind|0|0|NW_GetSidFromCluster|ind|ind|ind|ind|1|0|collectSharedDrives was executed with status ERROR ( Last error reported by the

    step :Cluster group isting status for resource 'L': does not exist.)

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      does user has authorizations ? add the user as local admin to server

      if L is not sapmnt drive, then why SAPINST looking for L drive. Can you add the T drive as part of the group ?

      1). Did you create FileServer ? The resource file server should be under group "SAP <SID>" should be named as "SAP <SID> FileServer" .

      Can you please confirm, you created group like below ?

      1.

      Open the Failover Cluster Management Console.

      2.

      Expand the navigation tree of the cluster.

      3.

      Right-click Services and Applications.

      4.

      Choose More Actions...Create Empty Service or Application.

      5.

      Rename the newly created service and application to SAP <SAPSID>.

      6.

      Right-click the service and application SAP <SAPSID> and choose Add Storage.

      7.

      Select the disk where the SAP instance is to be installed and choose OK.

      8.

      Right-click the service and application SAP <SAPSID>.

      9.

      Select Add a resourceClient Access Point.

      10.

      In the Client Access Point wizard, under Name enter the virtual host name for the SCS instance and choose Next and then Finish.

  • avatar image
    Former Member
    Jan 28, 2012 at 03:34 PM

    Hi Arjun,

    I have added the user to the local admin group.

    I have created cluster group SAP <SID> exactly the same way you described above. Also added fileserver as mentioned in NOTE 1490337 for Win R2 server.

    Still - SAME ERROR...

    T: is my SAPMNT drive which I am adding to the cluster group SAP <SID> but L: is used for SQL installation of Enterprise Portal and is part of SQL Server (EP) cluster group. In L:, we have many san disks of which will be used for storing datafiles and log files.

    Also , I have checked sapinstlog , and I found something peculiar. .-

    TRACE 2012-01-28 16:20:28.755 [synxcchapp.cpp:560]

    CSyChildApplicationImpl::doStart() lib=syslib module=syslib

    Trying to start cluster.exe using CreateProcess(NULL, <command line for executable cluster.exe, NULL, NULL, TRUE, 0x420, NULL, NULL, &StartupInfo, &ProcessInfo)

    TRACE 2012-01-28 16:20:28.759 [synxcchapp.cpp:638]

    CSyChildApplicationImpl::doStart() lib=syslib module=syslib

    A child process has been started. Pid = 20776. Executable name: cluster.exe

    INFO 2012-01-28 16:20:28.763

    CJSlibModule::writeInfo_impl()

    Output of cluster.exe RESOURCE L is written to the logfile cluster.exe.log.

    TRACE 2012-01-28 16:20:28.804 [synxcpipe.cpp:200]

    CSyStdOutErrPipe::onUnderflow(void * buf, int maxBytes, int timeout)

    lib=syslib module=syslib

    Syslib info about system call. OS message 109 (The pipe has been ended.

    ) after execution of system call 'ReadFile' with parameter ((read end of child process output pipe)), line (403) in file (synxcpipe.cpp).

    INFO 2012-01-28 16:20:28.813

    CJSlibModule::writeInfo_impl()

    Execution of the command "cluster.exe RESOURCE L" finished with return code 0. Output:

    Listing status for resource 'L':

    Resource Group Node Status

    -


    -


    -


    -


    L SQL Server (EP) goamsdb66 Online

    TRACE 2012-01-28 16:20:28.816

    ClusterMgt._callClusterExe() finished action: Get cluster group of resource 'L'. rc: 0, errorText: The operation completed successfully.

    This is in sapinst log file. So it is able to find L: - I dont know what is the issue here and why it is giving me the error.

    Also- it is successful in identifying I : ( as seen in sapinst log ) - which is part of SQL SERVER ( ECC) cluster group. It has many sans which will host ECC datafiles. We are yet to start ECC installation and we are sure that that too will give the error. I can see installation failing for PI, EP, ADS at this very step.

    Please help in this regard,

    Ankit

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Ankit,

      Remove the T drive from SAP <SID> group and add the T drive in file server SAP <SID> fileserver properties in dependencies tab.

      Please check T drive you can see in the list of drives and make sure T drive is part of cluster group SAP <SID> group and is online

      Can you try to share the T:\usr\sap as sapmnt and saploc and try again ?

      It's suppose to done by SAPinst but Its really sometimes wierd that sometimes we have to do it manually.

      Thanks,

      Arjun

  • avatar image
    Former Member
    Jan 28, 2012 at 04:07 PM

    Hi Arjun,

    Thanks for the reply.

    I have done the same thing. Added T: dependency to file server, T: is part of SAP <SID> group and still it is not working.

    There is no T:/usr/sap yet , because i am not able to start the installation yet. It is failing after two steps in giving parameters.

    Regards,

    Ankit

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 28, 2012 at 06:06 PM

    Restarted all servers which are part of the cluster node and restarted the inslattaion- still fails at the same place and with same error.

    Also, used modified installation master as described in the note 1152240 still fails with same error..

    I found one note 1299518 which details same issue but it is for maxdb and i am using ms sql.

    Please help,

    Ankit

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 31, 2012 at 10:36 PM

    issue resolved. Problem with L :

    Add comment
    10|10000 characters needed characters exceeded