Skip to Content
author's profile photo Former Member
Former Member

Text display missing on 0CALMONTH in BEX

Hi

We have just upgraded from BW3.5 to BI7.3.

After upgrade, we notice that Query Result for InfoObject 0CALMONTH is

not displaying TEXT value.

In the query , Column 0CALMONTH was reflecting as TEXT format before the

upgrade.After the upgrade, its displaying as KEY field only.

I tried to right click on BEX Result , Display As but it doesnu2019t have

the option for TEXT though in query design it has been designed to show

TEXT.

i found this link in SDN with similar issue but there is no resolution :

0CALMONTH - Short Text

Appreciate help from anyone who knows.

Thanks.

Regards

Maili

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Best Answer
    Posted on Jan 26, 2012 at 06:56 AM

    Hi,

    check following points

    1.first go to source system and right click and carry out transfer Global setting and transfer all the factory calendar etc.

    2. Carry out RSRV for Calmonth object

    3. check CALMONTH object and see for its text whether standard,short,medium and long etc in the report.

    4. Check for CALMONTH infoobject in the Bex property... and see whether only key is available..see in case you have to make changes to key and text..go to rsa1 ..double click on object and go to Bex property tab

    5. see if you need to reactivate Calmonth from business content again..

    6. Check report in RSRT as well

    7. Right click in report and see object property whether text option is available or not? standard/medium/small/long etc..

    Thanks and regards

    Kiran

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi ,

      This question had been raised with SAP OSS.

      The solution is to Tick 'with text' in RSD1 - Master Data tab.

      This is new feature in BI7 with its own implementation.

      Issue solved.

      Thank you for all the assistance from everyone.

      Regards

      Maili

  • author's profile photo Former Member
    Former Member
    Posted on Jan 25, 2012 at 08:47 AM

    Run report RSR_VARIANT_XPRA

    Run report RSR_MIGRATE_VARIANTS

    Regards,

    Sushant

    Add a comment
    10|10000 characters needed characters exceeded

    • Hi Maili

      Please check if the Text are maintained in English if you are login to BEx with english.

      Go to RSD5---->0CALMONTH -


      >Master Data /Text tab -


      > What is there under Master Data Read Class?

      Settings should be like this..

      Master Data Read Access - Own Implementation

      Name of Master Data Read Class ---CL_RSMD_RS_0CALMONTH

      This is a BI 7.0 onwards functionality ..probably that is the reason why this is not working now in your system but working in BW3.5.

      Please check this note for reference https://service.sap.com/sap/support/notes/1387166

      Regards

      Anindya

      Edited by: Anindya Bose on Jan 26, 2012 8:08 PM

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.