Skip to Content
avatar image
Former Member

System not not getting up after DB refresh from PRD to QAS

Dear Expert,

Good Morning,

i have done the DB refresh from PRD to QAS as per DB2 Redirect restore method. Data base has completely restore on QAS system and also db has activated but while i'm running the command startsap then its giving the such mention below error.

please se here below both error file startdb and r3trans -d.

-


Tue Jan 24 08:52:55 GMT+05:30 2012

LOGFILE FOR STARTING DB6 (DB2 UDB)

-


Tue Jan 24 08:52:55 GMT+05:30 2012

checking required environment variables

DB2INSTANCE is >db2qas<

INSTHOME is >/db2/db2qas<

DB2DBDFT is >QAS

-


Tue Jan 24 08:52:55 GMT+05:30 2012

starting database manager

01/24/2012 08:52:55 0 0 SQL1026N The database manager is already active.

SQL1026N The database manager is already active.

Database Manager started

SQL1490W Activate database is successful, however, the database has already

been activated on one or more nodes.

Activate database failed

-Tue Jan 24 08:52:56 GMT+05:30 2012

R3trans connect to the database

R3trans check finished with return code: 12

R3trans connect failed

Notify your SAP/database administrator

Tue Jan 24 08:52:57 GMT+05:30 2012

/usr/sap/QAS/SYS/exe/run/startdb: Terminating with error code 2

4 ETW000 R3trans version 6.14 (release 701 - 23.07.10 - 09:23:00).

4 ETW000 unicode enabled version

4 ETW000 ===============================================

4 ETW000

4 ETW000 date&time : 24.01.2012 - 08:58:11

4 ETW000 control file: <no ctrlfile>

4 ETW000 R3trans was called as follows: R3trans -d

4 ETW000 trace at level 2 opened for a given file pointer

4 ETW000 [dev trc ,00000] Tue Jan 24 08:58:11 2012 226 0.000226

4 ETW000 [dev trc ,00000] db_con_init called 25 0.000251

4 ETW000 [dev trc ,00000] create_con (con_name=R/3) 46 0.000297

4 ETW000 [dev trc ,00000] Loading DB library '/usr/sap/QAS/SYS/exe/run/dbdb6slib.o' ... 36 0.000333

4 ETW000 [dev trc ,00000] DlLoadLib() success: dlopen("/usr/sap/QAS/SYS/exe/run/dbdb6slib.o"), hdl 0

4 ETW000 547 0.000880

4 ETW000 [dev trc ,00000] Library '/usr/sap/QAS/SYS/exe/run/dbdb6slib.o' loaded 25 0.000905

4 ETW000 [dev trc ,00000] function DbSlExpFuns loaded from library /usr/sap/QAS/SYS/exe/run/dbdb6slib.o

4 ETW000 41 0.000946

4 ETW000 [dev trc ,00000] Version of '/usr/sap/QAS/SYS/exe/run/dbdb6slib.o' is "700.08", patchlevel (0.111)

4 ETW000 368 0.001314

4 ETW000 [dev trc ,00000] function dsql_db_init loaded from library /usr/sap/QAS/SYS/exe/run/dbdb6slib.o

4 ETW000 39 0.001353

4 ETW000 [dev trc ,00000] function dbdd_exp_funs loaded from library /usr/sap/QAS/SYS/exe/run/dbdb6slib.o

4 ETW000 42 0.001395

4 ETW000 [dev trc ,00000] New connection 0 created 30 0.001425

4 ETW000 [dev trc ,00000] 000: name = R/3, con_id = -000000001, state = DISCONNECTED, tx = NO , hc = NO , perm = YES,

4 ETW000 reco = NO , frco = NO , timeout = 000, con_max = 255, con_opt = 255, occ = NO

4 ETW000 64 0.001489

4 ETW000 [dev trc ,00000] db_con_connect (con_name=R/3) 51 0.001540

4 ETW000 [dev trc ,00000] find_con_by_name found the following connection for reuse: 26 0.001566

4 ETW000 [dev trc ,00000] 000: name = R/3, con_id = 000000000, state = DISCONNECTED, tx = NO , hc = NO , perm = YES,

4 ETW000 reco = NO , frco = NO , timeout = 000, con_max = 255, con_opt = 255, occ = NO

4 ETW000 61 0.001627

4 ETW000 [dev trc ,00000] DB6 (DB2 UDB) UNICODE database interface 700.08 [opt] 585 0.002212

4 ETW000 [dev trc ,00000] DB6 shared library (dbdb6slib) patchlevels 37 0.002249

4 ETW000 [dev trc ,00000] (0.2) DB6: patch collection 06/08 (note 1172220) 28 0.002277

4 ETW000 [dev trc ,00000] (0.9) DB6: reduce calls to REG_LIST_VARIABLES (note 1232030) 27 0.002304

4 ETW000 [dev trc ,00000] (0.10) DB6: UR cursor with CC_RELEASE attribute (note 1244963) 26 0.002330

4 ETW000 [dev trc ,00000] (0.10) DB6: DB6_DBSL_RUNSTATS_V8 with sampling rate (note 1245458)

4 ETW000 40 0.002370

4 ETW000 [dev trc ,00000] (0.11) DB6: trace warnings on setting SQL_ATTR_CHAINING_BEGIN (note 1247697)

4 ETW000 53 0.002423

4 ETW000 [dev trc ,00000] (0.19) DB6: patch collection 11/08 (note 1263885) 29 0.002452

4 ETW000 [dev trc ,00000] (0.19) DB6: patch collection 11/08 (note 1264825) 26 0.002478

4 ETW000 [dev trc ,00000] (0.21) DB6: SUBSITUTE_VALUES causes wrong estimated statement si (note 1277235)

4 ETW000 41 0.002519

4 ETW000 [dev trc ,00000] (0.33) DB6: patch collection 02/09 (note 1294443) 25 0.002544

4 ETW000 [dev trc ,00000] (0.36) DB6: cobra enhancements (note 1315762) 26 0.002570

4 ETW000 [dev trc ,00000] (0.40) DB6: configurable cc_release attribute for UR cursors (note 1324532)

4 ETW000 41 0.002611

4 ETW000 [dev trc ,00000] (0.41) DB6: unexpected token INLINE LENGTH (note 1334179) 25 0.002636

4 ETW000 [dev trc ,00000] (0.42) DB6: cobra enhancements part 2 (note 1315762) 26 0.002662

4 ETW000 [dev trc ,00000] (0.48) DB6: substitution of aliases in optguidelines (note 1352458)

4 ETW000 40 0.002702

4 ETW000 [dev trc ,00000] (0.53) DB6: login timeout for secondary connections (note 1364372)

4 ETW000 39 0.002741

4 ETW000 [dev trc ,00000] (0.57) DB6: revalidate views in status active=N (note 1376439) 31 0.002772

4 ETW000 [dev trc ,00000] (0.57) DB6: create index with 9.7 and virtual tables (note 1371882)

4 ETW000 41 0.002813

4 ETW000 [dev trc ,00000] (0.58) DB6: optimized performance for R3load with DEF_CRT (note 1378018)

4 ETW000 40 0.002853

4 ETW000 [dev trc ,00000] (0.62) DB6: timeout for CREATE/DROP TRIGGER (note 1387865) 26 0.002879

4 ETW000 [dev trc ,00000] DB2 library successfully loaded DB2 library '/usr/sap/QAS/SYS/global/db6/AIX_64/db6_clidriver/lib/libdb2.a(shr_64.o)' successfully loaded

4 ETW000 3116 0.006573

4 ETW000 [dev trc ,00000] Running with UTF-8 Unicode 39 0.006612

4 ETW000 [dev trc ,00000] Running with CLI driver. 3675 0.010287

4 ETW000 [dev trc ,00000] Tue Jan 24 08:58:13 2012 1350728 1.361015

4 ETW000 [dev trc ,00000] DB2 client driver version '09.01.0008' 33 1.361048

4 ETW000 [dev trc ,00000] Connected to DB server type 'DB2/AIX64' 52 1.361100

4 ETW000 [dev trc ,00000] Connected to DB server version '09.01.0008' 33 1.361133

4 ETW000 [dev trc ,00000] Connected to 'QAS' as 'SAPQAS' schema 'SAPQAS' o.k. 1111 1.362244

4 ETW000 [dev trc ,00000] Connected: con_hdl=0 ; appl_hdl=23; appl_id="192.168.10.6.57567.120124032813"

4 ETW000 45 1.362289

4 ETW000 [dev trc ,00000] Database code page is ok. 30 1.362319

4 ETW000 [dev trc ,00000] Database collating sequence is ok. 5296 1.367615

4 ETW000 [dev trc ,00000] *** ERROR in ExecuteDirect[dbdb6.c, 6385] CON = 0 (BEGIN) 10832 1.378447

4 ETW000 [dev trc ,00000] &+ DbSlConnectDB6( SQLExecDirect ): [IBM][CLI Driver][DB2/AIX64] SQL0551N "SAPQAS" does not have the privilege to pe

4 ETW000 57 1.378504

4 ETW000 [dev trc ,00000] &+ rform operation "DROP VIEW" on object "SAPTOOLS.DB2_WORKLOAD_CHECK". SQLSTATE=42501

4 ETW000 45 1.378549

4 ETW000 [dev trc ,00000] &+

4 ETW000 44 1.378593

4 ETW000 [dev trc ,00000] &+ DROP VIEW SAPTOOLS.DB2_WORKLOAD_CHECK

4 ETW000 45 1.378638

4 ETW000 [dev trc ,00000] &+

4 ETW000 45 1.378683

4 ETW000 [dev trc ,00000] &+

4 ETW000 45 1.378728

4 ETW000 [dev trc ,00000] *** ERROR in ExecuteDirect[dbdb6.c, 6385] (END) 39 1.378767

4 ETW000 [dev trc ,00000] On MCOD systems please "GRANT DROPIN ON SCHEMA SAPTOOLS TO USER SAPQAS " .

4 ETW000 48 1.378815

4 ETW000 [dev trc ,00000] DB2_WORKLOAD=SAP is set in DB2 registry as required. 144 1.378959

4 ETW000 [dev trc ,00000] CLI Insert Buffering is disabled on single partition databases. 830 1.379789

4 ETW000 [dev trc ,00000] INFO: Unable to determine SAPDBHOST; defaulting to 'UNKNOWN' 121 1.379910

4 ETW000 [dev trc ,00000] Connection 0 opened (DBSL handle 0) 51 1.379961

4 ETW000 [dev trc ,00000] INFO: Unable to determine SAPDBHOST; defaulting to 'UNKNOWN' 6378 1.386339

4 ETW000 [dev trc ,00000] *** ERROR in prepareStatement[dbdb6.c, 13630] CON = 0 (BEGIN) 876 1.387215

4 ETW000 [dev trc ,00000] &+ DbSlReadDB6( SQLExtendedPrepare ): [IBM][CLI Driver][DB2/AIX64] SQL0204N "SAPQAS.SVERS" is an undefined name. SQ

4 ETW000 49 1.387264

4 ETW000 [dev trc ,00000] &+ LSTATE=42704

4 ETW000 45 1.387309

4 ETW000 [dev trc ,00000] &+

4 ETW000 44 1.387353

4 ETW000 [dev trc ,00000] &+ SELECT VERSION FROM SVERS WITH UR

4 ETW000 45 1.387398

4 ETW000 [dev trc ,00000] &+ cursor type=NO_HOLD, isolation=UR, cc_release=YES, optlevel=5, degree=1, op_type=18, reopt=0

4 ETW000 47 1.387445

4 ETW000 [dev trc ,00000] &+

4 ETW000 45 1.387490

4 ETW000 [dev trc ,00000] &+

4 ETW000 44 1.387534

4 ETW000 [dev trc ,00000] *** ERROR in prepareStatement[dbdb6.c, 13630] (END) 27 1.387561

4 ETW000 [dblink ,01301] ***LOG BZA=>table SVERS does not exist on database [dblink#4 @ 1301]

4 ETW000 51 1.387612

4 ETW000 [dev trc ,00000] *** ERROR in prepareStatement[dbdb6.c, 13630] CON = 0 (BEGIN) 754 1.388366

4 ETW000 [dev trc ,00000] &+ DbSlReadDB6( SQLExtendedPrepare ): [IBM][CLI Driver][DB2/AIX64] SQL0204N

Edited by: Shiv ji Mishra on Jan 24, 2012 6:23 AM

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    Jan 24, 2012 at 05:41 AM

    Hi Shiv,

    Unable to determine SAPDBHOST; defaulting to 'UNKNOWN' 121 1.379910 4 ETW000 This might be your error.

    1). Check in the default profile for this parameter.

    2).Please check the file permissions of the dscdb6.conf file. and if required, you may have to follow SAP note 80292. Read it carefully

    3).You can also verify the following environment variables.

    4).If dscdb6.conf is not present at this location "
    mascon-sap2\sapmnt\<SID>\SYS\global\dscdb6.conf", you can create new one by executing the following command.

    dscdb6up -create <connect user password> <sidadm password>

    Have you edited the .csh & .sh profile and maintained correct schema ?

    Thanks,

    Arjun

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hello Shiv,

      It's a known error. Please delete old configuration in Domain controller and reconfigure. It should resolve your problem.

      Thanks,

      Siva Kumar

  • avatar image
    Former Member
    Feb 01, 2012 at 01:04 PM

    Hello,

    For getting rid of this issue you can delete the existing TMS configuration and then add the QAS system to the domain again and the going to transport routes and give the optin adjust with controller.

    For deleting the transport domain configuration you can use transaction se06,

    In se06 you have to choose option database copy or database migration and give perform post installation actions and except for changing originals from PRD to QAS give yes.

    Once you are done with these steps go to transaction STMS and add to different domain and give the details of the domain controller and then go to transport routes page and give adjust with controller menu option.

    Add comment
    10|10000 characters needed characters exceeded