Skip to Content

Component SAP ABA 7.02 does not show up in sproxy in CRM 7.0 EhP 1

We upgraded our CRM system from CRM 7.0 to CRM 7.0 EHP 1.

This involved an upgrade from NetWeaver 7.01 to 7.02, i.e. also ABA 7.01 to 7.02.

In sproxy in the CRM system we can only see

SAP CRM ABAP 7.0

SAP_BS_FOUNDATION 702

various custom software components.

SAP ABA 7.02 with the interfaces for e.g. business partner distribution is missing.

(When switching to the local view, they are shown and BP replication works.)

So I went into the SLD and looked at the technical system for CRM. Indeed the product "SAP NetWeaver SAP EhP 2 for SAP NetWeaver 7.0" was not marked as installed. So I added it. On the right-hand side under Software Component Versions "SAP ABA 7.02" is now listed.

i then went to the business system for one of the clients and also selected the product "SAP NetWeaver SAP EhP 2 for SAP NetWeaver 7.0" there and I can see the SWCV "SAP ABA 7.02".

I tried restarting both the PI and the CRM instances.

Nevertheless in sproxy in CRM nothing changed.

What else could be missing?

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Jan 23, 2012 at 10:58 AM

    Hi Monika,

    GO to CRM 7.0 system. and exactly check what version of the component is deployed over in CRM server.

    use the same version in PI end even. it will show up.

    a component will not show up in SPROXY only if there is component version mismatch.

    Cheers,

    Prakash.

    Add comment
    10|10000 characters needed characters exceeded

    • Monika Eggers senthilprakash selvaraj

      > To be very specific,

      >

      > Login to SAP CRM system.

      > Goto: SYSTEM-->status

      >

      > In there under SAP SYSTEM DATA group, you will be able to see a "Magnifying Lens" icon just below Component Version field --> click it

      >

      > there you will be able to see the exact version&level of the component.

      Yes, that's where I copied that line

      SAP_ABA 702 0009 SAPKA70209 Cross-Application Component

      from.

      > Now ask your basis team to deploy the same version&level in SAP PI as its shown in the CRM system.

      Ah, the PI/XI content could be missing, even if this shows up in the list of products and software component versions in the SLD?

      I have just checked in the ESR, that seems to be the problem, thanks.

      > Note: Thou the release version might be same, the level of the component deployed in both the system might be different. hence the problem.

      You mean if the service pack is different? I doubt that this would result in the SWCV not showing up in sproxy.

      Monika.

  • Jan 23, 2012 at 02:33 PM

    Hi Monika

    Check the note #1528587 PI ESR Content 0bjects are not visible in SPROXY.

    Regards

    Mark

    Add comment
    10|10000 characters needed characters exceeded