Skip to Content
avatar image
Former Member

SAP startup failure after DB2 upgrade 9.5 to 9.7

Hi All,

We have upgraded DB2 Database from 9.5 to 9.7 in Development system.We are unable to stsart the SAP.Please find trans.log details below.

Checking db Database

-


ABAP Database is not available via R3trans

Starting SAP-Collector Daemon

-


***********************************************************************

  • This is Saposcol Version COLL 20.95 700 - AIX v11.15 5L-64 bit 080317

  • Usage: saposcol -l: Start OS Collector

  • saposcol -k: Stop OS Collector

  • saposcol -d: OS Collector Dialog Mode

  • saposcol -s: OS Collector Status

  • The OS Collector (PID 8912994) is already running .....

************************************************************************

saposcol already running

ABAP Database db must be started on remote server

-


4 ETW000 [dev trc ,00000] (0.274) DB6: DROP INDEX on virtual table ignored (note 1514380) 30 0.008760

4 ETW000 [dev trc ,00000] (0.277) DB6: FOR ALL ENTRIES statement with SUBSTITUTE LITERALS (note 1520152)

4 ETW000 41 0.008801

4 ETW000 [dev trc ,00000] (0.279) DB6: SQL0301N after LONG to LOB conversion (note 1524339) 25 0.008826

4 ETW000 [dev trc ,00000] Supported features: 22 0.008848

4 ETW000 [dev trc ,00000] ..retrieving configuration parameters 35 0.008883

4 ETW000 [dev trc ,00000] ..done 118 0.009001

4 ETW000 [dev trc ,00000] DB2 library successfully loaded DB2 library '/home/fbeadm/sqllib/lib64/libdb2.a(shr_64.o)' successfully loaded

4 ETW000 13885 0.022886

4 ETW000 [dev trc ,00000] Running with UTF-8 Unicode 25 0.022911

4 ETW000 [dev trc ,00000] Running with CLI runtime client libraries. 6880 0.029791

4 ETW000 [dev trc ,00000] Fri Jan 20 15:35:34 2012 611496 0.641287

4 ETW000 [dev trc ,00000] *** ERROR in DB6Connect[dbdb6.c, 1786] CON = 0 (BEGIN) 104 0.641391

4 ETW000 [dev trc ,00000] &+ DbSlConnectDB6( SQLConnect ): [IBM][CLI Driver] SQL1031N The database directory cannot be found on the indicated

4 ETW000 49 0.641440

4 ETW000 [dev trc ,00000] &+ file system. SQLSTATE=58031

4 ETW000 42 0.641482

4 ETW000 [dev trc ,00000] &+

4 ETW000 41 0.641523

4 ETW000 [dev trc ,00000] &+

4 ETW000 42 0.641565

4 ETW000 [dev trc ,00000] &+

4 ETW000 68 0.641633

4 ETW000 [dev trc ,00000] *** ERROR in DB6Connect[dbdb6.c, 1786] (END) 26 0.641659

4 ETW000 [dbdb6.c ,00000] *** ERROR => DbSlConnect to 'FBE' as 'sapfbe' failed 86 0.641745

2EETW169 no connect possible: "DBMS = DB6 --- DB2DBDFT = 'FBE'"

-


Could you please help into this issue?

Regrads,

Mani

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

5 Answers

  • avatar image
    Former Member
    Jan 20, 2012 at 03:52 PM

    Hello Mani,

    Have you updated DB instance after upgrade?

    Thanks,

    Siva Kumar

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 20, 2012 at 03:57 PM

    Hi,

    Can you check db2nodes.cfg for hostnames and IP address ? Use the service IP address in db2nodes.cfg and check.

    Thanks,

    Arjun

    Add comment
    10|10000 characters needed characters exceeded

    • Hi All,

      >

      > It showing sid<adm> instant of db2<sid>.Please help us.

      >

      > sidadm> db2level

      > DB21085I Instance "sidadm" uses "64" bits and DB2 code release "SQL09074" with

      > level identifier "08050107".

      > Informational tokens are "DB2 v9.7.0.4", "s110330", "IP23236", and Fix Pack

      > "4".

      > Product is installed at "/home/fbeadm/sqllib".

      I think this should be at /db2/db2fbe/db2_software

  • avatar image
    Former Member
    Jan 24, 2012 at 11:33 PM

    Hello,

    Are you able to see that all the services have started?

    Since this is Development system on AIX i believe you have DB+CI on same system/node.

    Try starting the database alone first and see if it starts.

    For the error you are getting, execute the following commands and see what is listed.

    db2 list database directory

    db2 list node directory

    Please check what each of the command reports and check if this directory exists or

    is mounted and has sufficient permissions.

    Make sure you have run the scripts db6_update_db or db6_update_client attached to

    SAP Note 1365982.

    Read the SAP Note 1332109 - DB6: Upgrade to Version 9.7 of DB2 and check if you have missed anything.

    Additionally, check SAP Note 1329179 - DB6: DB2 V9.7 Standard Parameter Settings

    Regards,

    Sai

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 25, 2012 at 08:49 PM

    Please check my earlier post and let us know what the commands result in.

    Regards,

    Sai

    Add comment
    10|10000 characters needed characters exceeded

    • hi

      please check

      SQL1027N

      The node directory cannot be found.

      Explanation

      The list node directory command cannot be processed because the node directory could not be found.

      The command cannot be processed.

      User response

      Issue a CATALOG NODE command with the appropriate parameters and resubmit the current command.

      Please maintain Separate entries in both systems in db2nodes.cfg. then copy one directory from node a (db2 directory).

      Thanks

      Sadiq

  • avatar image
    Former Member
    Feb 02, 2012 at 12:08 AM

    Hi,

    Download the latest kernel on database independent from service market place for ur platform

    and then restart... it may work out....

    thanks and regards,

    santosh

    Add comment
    10|10000 characters needed characters exceeded