Skip to Content
avatar image
Former Member

DDIC action error phase ACT_UPG shadow instance

Dear all,

Can I please ask you to help me with the following problem.

We are actually performing an upgrade of a test system from SAP Enterprise 470X110 to ECC 604.

Unfortunately we are actually facing a problem in the phase ACT_UPG within the shadow instance (upgrade step PREPROCESSING).

The upgrade faced a problem to activate a Z table.

---

~DDIC ACTIVATION ERRORS and RETURN CODE in SAPAAAA701.HRY~

~1EEDO519X"Table" "ZDEB2" could not be activated~

1EEDO519 "Table" "ZDEB2" could not be activated

1 ETP111 exit code : "8"

---

We tried the following to solve the problem by ourselves.

- Signed in to the shadow instance with a normal user ID (copy of DDIC).

- Performed a check on the table with transaction SE11 which gave the following result.

---

Key field LADNR has unpermitted type

Field LADNR: Component type or domain used not active or does not exist

Nametab for table ZDEB2 cannot be generated

---

By this we discovered that the field LADNR was only partial configured.

So we discussed how to proceed with this table in general.

In general we don't require the table anymore so we can delete the table in principle,

but due to the fact that we are not sure how the upgrade is reacting if we delete the table from the shadow instance,

we decided to first of all give it a try to repair the table.

So we went on and removed the field LADNR from the table ZDEB2.

Afterwards we tried to activate the table but this gave some further error message about

that the technical settings for this table are not maintained.

So we also maintained the technical settings and added the data class APPL0 and the size category 8 (we have chosen these values just to be able to proceed).

Afterwards we tried again to activate the table.

This time we got the following message:

---

Enhancement category for table missing

Enhancement category for include or subtype missing

Old key field LADNR has been deleted

Structure change at field level (convert table ZDEB2)

Check on table ZDEB2 resulted in errors

---

The help text of the error line 'Structure change at field level (convert table ZDEB2)' proposed to do a conversion of the table via SE14.

So we tried to convert the table via SE14 but also this ended with errors (see below).

---

Request: Force conversion Table ZDEB2

Nametab of table ZDEB2 with status A does not exist

Enhancement category for table missing

Enhancement category for include or subtype missing

Test activation of Table ZDEB2 successful

Nametab of table ZDEB2 with status A does not exist

Request for ZDEB2 could not be executed

---

After this we checked the database and runtime object.

The database object check ended successully but is still showing the delete field LADNR.

Also the primary index for the database object is still showing the field LADNR.

The runtime object check ended with errors.

---

Active DDIC source for ZDEB2 missing or incorrect

---

So here are we now and actually do not know how we should proceed.

The activation of the table is giving an error as we should do a conversion first of all.

The conversion is giving an error as the runtime object is missing.

Has anyone an idea how we can proceed?

Again, we don't need the table anymore so in worst case we could also delete the table from the shadow instance

but we first of all decided to give it a try to repair the table as we don't know the consequences for the following steps of the upgrade, if the table is not available anymore.

If we can fix the problem in the shadow instance

then we would for sure also like to use the same procedure for the live system

so that the problem will not repeat later on when we proceed with the upgrade.

With live system I am talking about the system that was used to create the shadow instance.

Best regards

MADFISI

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Jan 20, 2012 at 04:26 PM

    Hello,

    You have to understand one aspect of the upgrade. As you are aware , a shadow system will be built. In the EU_IMPORT

    phase , the objects coming in the suppot packages and addons are used to build the target repository ( target release ).

    The shadow system will start uisng the target repository. This shadow system only contains the active nametabs for standard SAP structures. The Zstructutres and the Zobjects in the customer name space may not always be consistent here since they

    are not always present in the shadow nametab repository. Now to if there exists an entry in the TADIR table in the shadow system for a Zobject then it is sure that the Z object will be present in the target release after the upgrade. One more hint is you can check the DIFFEXP.LOG and CUSTEXP.log in the <DIR_PUT>/ABAP/log directory for an entry of the zstructures. Seeing this log you can understand how the object will be handled during an upgrade. You will know wheterh the upgrade is deleting it or keeping it in the target release. Usally all the Zobjects will be carried forward during an upgrade .

    Now coming to your problem. Please check initially if the object in qustion is consistent in your source system release. If it is not consistnet , nothing much can be done. The object will be imported the way it is in the target release and you will have to correct it after the upgrade. Now if the object is consistnet in the source system then you can ignore this error in the ACT_UPG phase as non-severs error and continue. The nametab for the object will be constructed in the later part of the upgrade. So there is no need to worry. Now since you have made some changes in the object , try to continue. If the object is really inconsistent during the upgrade , it will come up as error again in PARCOV phase where in you have to correct it to move forward.

    I hope I was clear . Let me know in case of any doubts.

    Regards,

    Varun.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hello Varun,

      Thank you very much for you explanation and for your proposal how to proceed.

      After some further adjustments I was able to activate the table more or less.

      I added the missing field LADNR again but instead of using the missing data element LADNR I mainateind the data type and length by myself (button DATA ELEMENT / Built-in type).

      This time the activation via SE11 ended only with warnings and more or less succeeded but a check of the database and runtime object showed an inconsistence.

      But as I alredy mentioned, we don't need the table later on so in our case it was ok to keep the object in this state.

      Afterwards I repeated the phase again with the option 'Repeat phase ACT_UPG to continue at the point it stopped'.

      Also this time the phase stopped again.

      I reviewed the log files again and as far as I have seen within the log files, this time the upgrade was able to activate the table ZDEB2.

      So to be honest I don't know why the upgrade again faced a problem.

      Finally we continued with the upgrade as proposed by you.

      We used the option 'Accept non-severe errors and repeat phase ACT_UPG.

      Till now we have not faced any new errors related to this table.

      I will update this message as soon as the upgrade is finished and let you know if we have faced additional problems.

      Again thank you very much for your help.

      Best regards

      MADFISI

  • avatar image
    Former Member
    Jan 20, 2012 at 11:53 AM

    hi

    check that table and activate it or proceed further then after upgrade you will activate this table.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hello AP,

      Thank you for your answer but that is our problem.

      We are not able to activate the table.

      First of all, the upgrade tried to activate the table but was not able too.

      That is the reason why we are working on this problem because the upgrade stopped due to the activation problem.

      As describe above we tried different activities to get the table acivated.

      Best regards

      MADFISI