Skip to Content
Jan 19, 2012 at 07:22 PM

No export files from sapinst? (BI Unicode conversion)



I have a problem that has been driving me crazy. I have a BI 7.0 non-unicode system that I am upgrading to unicode. I've done all of the prereq steps, including running the DDL generation program inside of SAP. I moved those files into my dump subdirectories. When I run sapinst and start the export preparation, I can see that the system generates a ton of DDL<db>.tpl EXT and STR files. But when the prep step finishes, all of the files are gone from the dump dirs. If I try to start migmon's export_monitor, it expects at least the DDLORA.TPL file.

I have two options. I found all of the files backed up under the /tmp/sapinst_instdir/... subdirectory for the logs. I can also generate the TPL files if I manually run R3load. But I shouldn't have to, right? Why is sapinst creating the files, and then removing them? When I am done running the DB export step from sapinst, the files should be there, right?

Next, so I have moved the files back out of the sapinst_instdir into the dump dir. When I run it reads them and starts the export. The problem is that it runs for about 45-60 minutes, and I am left with a DATA dir with only 7GB of data. My source BI system is a little over 220 GB. The 'empty' DB I created uses about 50 GB, so even allowing for indexes and temp, that can't account for the missing 150+GB of missing data.

After using sapinst to set up the new DB I tried to run the, just for fun, and it blows up trying to import the SAP0000 files, because it says there is no entries in SAPUSER. I think there is a whole set of tables that are not in the export.

Can anyone give me any tips on this? Why isn't sapinst generating the control files for the export, and where is the data? For reference, I have the latest R3load, R3ldctl, R3szchk, dblib, and I am using the latest MIGMON.SAR files.