Skip to Content
avatar image
Former Member

No export files from sapinst? (BI Unicode conversion)

Hello,

I have a problem that has been driving me crazy. I have a BI 7.0 non-unicode system that I am upgrading to unicode. I've done all of the prereq steps, including running the DDL generation program inside of SAP. I moved those files into my dump subdirectories. When I run sapinst and start the export preparation, I can see that the system generates a ton of DDL<db>.tpl EXT and STR files. But when the prep step finishes, all of the files are gone from the dump dirs. If I try to start migmon's export_monitor, it expects at least the DDLORA.TPL file.

I have two options. I found all of the files backed up under the /tmp/sapinst_instdir/... subdirectory for the logs. I can also generate the TPL files if I manually run R3load. But I shouldn't have to, right? Why is sapinst creating the files, and then removing them? When I am done running the DB export step from sapinst, the files should be there, right?

Next, so I have moved the files back out of the sapinst_instdir into the dump dir. When I run export_monitor.sh it reads them and starts the export. The problem is that it runs for about 45-60 minutes, and I am left with a DATA dir with only 7GB of data. My source BI system is a little over 220 GB. The 'empty' DB I created uses about 50 GB, so even allowing for indexes and temp, that can't account for the missing 150+GB of missing data.

After using sapinst to set up the new DB I tried to run the import_monitor.sh, just for fun, and it blows up trying to import the SAP0000 files, because it says there is no entries in SAPUSER. I think there is a whole set of tables that are not in the export.

Can anyone give me any tips on this? Why isn't sapinst generating the control files for the export, and where is the data? For reference, I have the latest R3load, R3ldctl, R3szchk, dblib, and I am using the latest MIGMON.SAR files.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Jan 20, 2012 at 09:01 AM

    Hi Randall,

    You need to check in your export dump directory whether following entries are present or not post export preparation

    DATA

    DB

    LABEL.ASC

    Since your database size is 220 GB, you export dump will never be of the same size. Export dump will be around somewhere around 10% of your actual size. So your export dump size of 7GB looks fine.

    Since you have BI 7.0 , I would suggest you to use SAPINST to perform all the operations. This will make life easy.

    Regards,

    Deepak Kori

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Thanks Deepak, I'm trying to understand how a 220GB+ system can be compressed to 7GB. I can understand some shrinkage because of temp space and indexes, but that seems pretty extreme. I would have expected 70-90GB. Even 10% is 3x what I have.

      The problem I am having is with sapinst. When I run the Export steps, all I am left with is exactly what you list. Just the LABEL, and the empty DATA and DB dir trees. sapinst finishes, says it was sucessful, but then when I fire up MIGMON to actually start the export, it is looking for DDLORA.TPL, and the EXT and STR files. Based on what I am reading, sapinst is supposed to create those (and I see them being generated during the PREP phase), but if I don't move things manually, export_monitor.sh just sees empty directories.

      Let's do it a different way. Once you have completed running the sapinst export steps, what files are in the <export dir> that MIGMON is supposed to pick up and use?

  • avatar image
    Former Member
    Jan 24, 2012 at 02:29 PM

    OK. Well couldn't exactly figure it out, but I did figure out to switch to Distribution Monitor, rather than MIGMON. DISTMON must have better smarts, because it allowed the export. Now if I could figure out why my import isn't working....

    Add comment
    10|10000 characters needed characters exceeded