Skip to Content
avatar image
Former Member

Error "XML tag Main/@versionMinor has incorrect value 001; expected value."

I'm going to describe our scenario.

We have created an Abap proxy in a BW system to run a XI interface. The abap proxy in BW is connected to the IE of a XI 3.0 system. That scenario runs without problems with BW 3.5 (basis 6.40). Now, we are migrating the release of BW to 7.30. we have created the Abap proxy in the migrated BW system but when we run the interface the next message is returned:

<?xml version="1.0" encoding="UTF-8" standalone="yes" ?>

- <!-- Call Integration Server

-->

- http://sap.com/xi/XI/Message/30" xmlns:SOAP=" http://schemas.xmlsoap.org/soap/envelope/">

<SAP:Category>XIProtocol</SAP:Category>

<SAP:Code area="PARSER">UNEXPECTED_VALUE</SAP:Code>

<SAP:P1>Main/@versionMinor</SAP:P1>

<SAP:P2>001</SAP:P2>

<SAP:P3>000</SAP:P3>

<SAP:P4 />

<SAP:AdditionalText />

<SAP:Stack>XML tag Main/@versionMinor has the incorrect value 001. Value 000 expected</SAP:Stack>

<SAP:Retry>N</SAP:Retry>

</SAP:Error>

does anyone know what the problem is? is there a version conflict between BW 7.3 and XI 3.0?

Thanks very much

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Jan 16, 2012 at 04:16 PM

    Hi,

    I'm not an expert, but it might be that you would also need to update the XI content to match the new release and then regenerate the proxy.

    It does indeed seem to be a difference in the version of the proxies between BW 3.5 and BW 7.3.

    Regards,

    Horia

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 17, 2013 at 07:47 AM

    Hello Alberto,

    We are facing the same problems.

    What was your solution. Do we really need to upgrade our XI-systems first ?

    Kind regards,

    Gert-Jan

    Add comment
    10|10000 characters needed characters exceeded