Skip to Content
0

Std. PO picking customer address by default .

Dec 22, 2016 at 03:17 PM

55

avatar image

Hi Experts,

I need your help,

I came across one issue where plant is also maintained as customer so while creating std PO, it is picking customer address and sometime plant address .. though the address details are same .

The real issue is while PO is having multiple line item and when user changes or adds new item at that moment if customer address is picked and changed order type is sent to other system ORDCHG, we have mapping E1EDKA1 WE segment at header level but when address gets changes at item level ,this segment disapperas and a new segment E1EDPA1 WE attached at item level.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

4 Answers

Vikash Sharma Dec 22, 2016 at 03:30 PM
0

refer snipshot..


capture.png (146.6 kB)
Show 1 Share
10 |10000 characters needed characters left characters exceeded

your screenshot does not look consistent, it shows item [210] at item level, but in the overview you start with item 211, so we cannot see account assignment and item category of item 210 and hence cannot know whether the value is right or wrong.

Also it is not really clear where you change items when you work with Idocs, this has to be explained in very detail.

0
Vikash Sharma Dec 22, 2016 at 03:52 PM
0

Sorry Dear...refer this one


capture2.png (81.1 kB)
Share
10 |10000 characters needed characters left characters exceeded
Vikash Sharma Dec 22, 2016 at 03:58 PM
0

This PO is std PO and it does not have any item category or account assignment category in any item .
As this is std process so in ME21N when user is creating PO, customer field is not displaying and in change mode if user is making changes in address .. suppose changing "Title" then customer num gets(This customer and plant address details are same) updated but can not see in ME22N as well, but when displayinig in ME23N it is showing Customer address...

also there is no assignment with this customer and plant.

Share
10 |10000 characters needed characters left characters exceeded
Jürgen L
Dec 22, 2016 at 04:17 PM
0

I would suggest to contact your local Support team first, check if they had recently done some development in this area.

Or if an upgrade was done or implementation of Hotfixes.

This is certainly a bug, and I would actually link it to own development, especially as I already see the "Customer Data" tab in your screenshot, which confirms that a BAdI is in use.

Transaction ANST can be used to analyze the transaction, it will show the own developments.

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Thanks dear, but could you please help me to understanding how address determination works, I am quit confuse .
Generally by defualt it should be plant address, in 3rd Party PO it would be customer address , if user is making any changes then address will store in EKPO with an address number .. apart from this .. how determination works

please correct me if I am wrong .

0