Skip to Content
avatar image
Former Member

SAP Solution Manager - Patching Java-Stack

Hello community!

I have got a question about patching the Java-Stack of our SAP Solution Manager.

First of all, I would like to give you a short overview about our landscape:

- SAP Soluation Manager SPS27, Dual-Stack-System

- Installed Products:

+ ABAP-Stack: Solution Manager

+ Java-Stack: SLD, NWDI

Our ABAP-Stack is on SP8, our Java-Stack on SP8, too.

My Question:

Are there any risks / is it adisable to patch only the Java-Stack from SP8 to SP10 and not both Stacks from SP8 to SP10 ?

Thank you very much for answering.

Best Regards.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • avatar image
    Former Member
    Jan 12, 2012 at 08:49 AM

    Hi

    IMHO, as Solution Manager needs both stacks and if you are using BI for Solution Manager on same system, I would upgrade both stacks at (nearby) same time. Just don't forget to check SOLMAN_SETUP afterwards.

    Best regards,

    Michael

    Add comment
    10|10000 characters needed characters exceeded

    • Hi,

      As SAP best practise, always ensure ABAP and JAVA on the same stack.

      If you just decide to use some simple feature on SOLMAN (EWA, MOPZ), and not rely much on the java instance, it shouldn't give you any problem by just upgrading the JAVA stack. However, please perform a backup for your system, just in case.

      Thanks,

      Nicholas Chang

  • avatar image
    Former Member
    Jan 12, 2012 at 06:22 PM

    Hello,

    The correct procedure is go to the next solman stack. Solman 7.01 SPS28 has a specific stack definition. Check under http://service.sap.com/sp-stacks ->SAP enhancement package 1 for SAP Solution Manager 7.0

    and "show SP stack content" for SPS28.

    You'll be able to see that SPS28 uses SAP_ABA and SAP_BASIS SP10, the java core is also SP10, but not all components are in SP10, for example SOLMANDIAG 7.01 for SPS28 is SP11.

    Then, the point is, you should install SPS28 with all the required components instead of patching some components individually.

    Just to give you another hint in this direction, check Note 1509718:

    "2. Deploy the new LM-SERVICE sca, which provides in one shipment all known and implemented fixes. This LM-SERVICE Java Software component MUST be implemented together with the relevant ABAP ST 400 software component."

    Cheers,

    Diego.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Nicholas Chang

      Hello,

      100 % agree with Nicholas. The supported configuration is the stack configuration. If you chose another "mix" of components maybe works, maybe not, depending of the scenarios you implement, but definitely is not supported by SAP.

      Cheers,

      Diego.

  • Jan 13, 2012 at 05:25 PM

    The official SP Stacks supported by SAP are described in details in note 1274287.

    There are some components that are backward compatible for example JSPM and SWLIFECYCL, you can have the latest SP level with latest patch level.

    There are some components in ABAP side that you also can apply patches, for example ST-PI, ST-A/PI, ST-ICO, etc.

    The core Netweaver components and ST400 depends of each other.

    Add comment
    10|10000 characters needed characters exceeded