Skip to Content

SAP GUI Connect from Eclipse

Hi Experts,
From my Eclipse editors(LUNA or Juno), i am trying to connect to my SAP GUI to start with ABAP developments.
After giving the SAP login credentials, i am getting an error "com/sap/mw/jco3/eclipse/Registry".


I am trying this on both Eclipse editors 'Juno' & 'Luna'.

I can see that the required ADT tools are already installed from

https://tools.hana.ondemand.com.
Also, upon opening the eclipse editor its issuing a pop up like "ABAP communication layer is not configured properly"..etc Pls suggest

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

6 Answers

  • Jan 02, 2017 at 02:47 PM

    I came to know that my backend ECC ABAP should be 7.03/ 7.31 SP4 (SAP_ABA, SAP_BASIS comps) and above.

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 10, 2017 at 10:58 AM

    Hi Ricky,

    you need at least AS ABAP 7.31 to work with eclipse.

    Regards,

    Thomas.

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 23, 2016 at 06:57 PM

    Hi,

    Could you please update to eclipse Neon and ADT 2.68 and try again

    Regards,

    Thomas.

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 25, 2016 at 02:41 AM

    Ok. will try and let you know.

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 25, 2016 at 07:29 PM


    Hi Thomas,

    As you suggested, I downloaded Eclipse Neon and updated the ADT 22.68.
    I am still unable to connect to SAP GUI. I am seeing that the ECC is 6.0 and SAP_BASIS component version is 700.
    Could that be a reason? Any more suggestions?

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 02, 2017 at 02:25 PM

    can any one answer this please

    Add comment
    10|10000 characters needed characters exceeded