Skip to Content
avatar image
Former Member

Chinese characters appear OK in preview but not when printed

I am working on sap script .

In which I am facing problem in printing Chinese character.

In the spool(print preview) I am able to see Chinese characters printed but while printing on a paper it is appearing as '#' Characters.

I am using Font Family as COURIER in basic settings and If I try changing Font to CHSONG(Chinese character font), alignment getting distorted.

I have tried several options available in SDN, but not able to find exact solution on the issue.

Please help me with proper solution.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Jan 06, 2012 at 04:42 PM

    In chsong it is coming correct right...? If yes then you have to use this font only and adjust the alignment for chinese sap scrpit...

    Nabheet

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 07, 2012 at 07:47 AM

    HI friend,

    Try changing the device type which suits the Chinese font. There are many device types which support device types.

    Example : CNSAPWIN.

    Just try this friend. If you face queries please revert back to me i will help you.

    Thanks,

    Sri Hari

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 14, 2016 at 08:27 AM

    Hi,
    We are facing similar issues for smartform.
    In print preview we get right output. All chinese text is in SimSun font. In print preview we get correct display. All text appears in SimSun font. While printing one field changes to another font. Rest all fields print correctly in SimSun font. One field changes to other font which looks odd.

    Please share your experience how you resolved it.
    Thanks.

    Add comment
    10|10000 characters needed characters exceeded