Skip to Content
avatar image
Former Member

OUTBOUND XML FILE CONTAINS SPECIAL CHARS AFTER SP08 UPGRADE

Experts,

Recently MDM server upgraded to SP08 from SP05.

In our outbound interface scenario we have 1 hierarchy field. The hierarchy field mapped as complete path(parent to Child)

ex: 1,Parent > 11,Child > 111,Child > 1111,Child.

In SP05 XML files are generating correctly & PI also dont have any issues while passing this data to ECC.

After SP08 Server pack upgrade, xml file generating like below:

1??, ??Parent??, ???>?11??, ??Child??, ???>?111??, ??Child??, ???>?1111??, ??Child??, ???

If open the xml file in non ASCC editor I could able to see these special chars. Due to this ISSUE PI could not processing xml files.

All XML files are failing& blocking in PI.

Could you let me know what needs to be done at MDM or PI level.

Appreciate your inputs.

Thanks

Audinarayana

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Jan 06, 2012 at 10:42 AM

    Hi,

    Try the steps :

    Unload the repository .

    Restart the server

    Load with option update indices.

    Hopefully it should work.

    Regards,

    Neethu Joy

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 06, 2012 at 11:11 AM

    Hello,

    Please check the Destination preview in the syndicator.

    So an syndication on the local machine, open the XML in an Browser, to see check for the special characters.

    If every things is ok, then just place the file in the outbound ready folder.

    If not then, raise an OSS message with SAP, as this a latest release, error resolution would be best provided by SAP

    Regards,

    Abhishek

    Add comment
    10|10000 characters needed characters exceeded