Skip to Content

ATD Check Issue in creation TLB Order Manually in Planning Book.

Hi ,

I am facing issue in ATD Check in TLB Interactive Planning while creating TLB Order Manually.

Here goes scenario.

I am creating TLB Order Manually in TLB Planning Book with below Information.

Demand Date u2013 02.01.2012 ( Todayu2019s date ) & Qty u2013 20

Considering Lead Time of 10 Days to supply from Plant to Depot, Delivery Date in Purchase Order is calculated as 12.01.2012

Now I do outbound delivery for this PO in ECC. As client is not using Routes Transit Times functionalities, Planned Goods Issue Date for Outbound Delivery in ECC is calculated as Delivery Date from PO which is 12.01.2012 minus Transit Time in Route which is maintained as 0. Hence Planned Goods Issue Date in ECC is 12.01.2012.

This is same as Requirement Date for Outbound Delivery. PGI for this delivery is yet to happen. When PGI is done then issue is resolved.

When this Delivery goes in APO, it has requirement date as 12.01.2012 and now when I create TLB Order in Interactive Planning Book manually it allows me to create TLB Order of 20 qty extra before populating below message

u201CThere is only an ATD quantity of XXX available for product GHECP02u201D

In short it allows me to create 20 extra PO as Outbound Delivery is shifted to future bucketu2019s and hence is not counted in ATD Issues.

I am using Daily Bucket Profile in TLB Planning Book.

If I use Monthly Bucket Profile my issue is solved but again when client is creating TLB Order , by default system picks first date of bucket which client does not want.

Is there any way where in I can avoid this excess PO Creation. When it checks ATD Availability it should consider these outbound deliveries which are of future dates.

Regards,

Sameer

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    Nov 16, 2012 at 11:56 AM

    Hi,

    Main culprit for this Issue is Transit Time maintained in ECC in Routes are not in sync with T Lanes Times maintained in APO.

    To solve this issue below are possible solutions

    1] Maintain correct Transit time in Routes in ECC.

    2] While creating outbound deliveries in ECC, bypass logic of calculating Outbound Delivery Date which is availability date at Depot less Transit time maintained in routes and use user exit to populate current date as Outbound Delivery date.

    We have adopted second option and issue is resolved.

    Regards,

    Sameer Karbotker

    Add comment
    10|10000 characters needed characters exceeded

  • Jan 02, 2012 at 01:29 PM

    Hi Sameer,

    Such kind of issues would come when master data/transaction data in APO and R/3 are not in sync.

    You could go in for some custom development for TLB orders, but it's like opening a pandora's box as you are messing with teh standard working of system. It could create data inconsistencies between APO and R/3 and I would not really advise this. It's best to maintain all the relevant master data/transaction between APO and R/3 in sync.

    Better ask your client to maintain the relevant routes as required. Otherwise they should create PO directly in R/3 as required.

    Thanks - Pawan

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 03, 2012 at 02:20 PM

    Hi Sameer,

    If you do not want to maintain routes in ECC,

    Please use the exit "EXIT_/SAPAPO/SAPLCIF_PU_001" to modify the PO scheduling when the PO is re-transferred from APO to R/3. In this exit you can read the lead time between the locations and change the scheduling dates for the P.O (you can change GI date from 12/01 to 2/01 here so your ATD computation also will be correct).

    We are using this exit for PO rescheduling (for a different reqmt) and it works fine.

    Regards,

    Ashok

    Add comment
    10|10000 characters needed characters exceeded