Skip to Content
avatar image
Former Member

ABAP runtime error: snap_no_new_entry

Hi All,

We got the above error.

We tried ST22 --> Go to --> Till here I can go only.....I am not able to Reorganize.

As well as I tried Reorganize again its Throw the DUMP.

Plz Suggest Other Answer.

Regards,

Rableen

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Dec 29, 2011 at 01:23 PM

    Hi Rableen,

    Check SAP Note 17537 - ABAP/4 runtime error SNAP_NO_NEW_ENTRY.

    Also check your transactional log, this error also occurs when transaction is full.

    On which database are you ?

    Regards,

    Sreeni.

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Rableen,

      From MSSQL Enterprise manager connect to your database.

      Select the database instance specific to your installation.

      Check out the data files and log files definition for your SID. Right clik on the transaction log and there you can find option to shrink it.

      In case your transaction log is full, you can go with the following options

      1) Take transaction log backup

      2) Add a new log directory using the step mentioned above.

      Regards,

      Deepak Kori

  • avatar image
    Former Member
    Dec 30, 2011 at 05:44 AM

    Hi Rableen,

    There could be many reasons for this dump. But I have faced this problem many time when /db2/SID/log_dir is full when archiving to TSM failed. In this case you can't even reorganize SNAP from ST22.

    So I suggest you to check your MSSQL archiving status and filesystem usage.

    Hope it helps.

    Thanks,

    Siva Kumar

    Edited by: Siva Kumar Arivinti on Dec 30, 2011 11:15 AM

    Add comment
    10|10000 characters needed characters exceeded