Skip to Content
0
Former Member
Apr 21, 2005 at 08:57 PM

SDM password issue

33 Views

Hi

From my NW studio, I am not able to deploy my web dynpro applications directly into SDM. Somehow the password is not correct. Here are few things I tried & don't know where to go from here....

1) Changed the password of SDM using the changepassword command. Restarted J2EE server, NW studio & tried new password I still get the following error...

Used following command:

C:\usr\sap\JKS\JC00\SDM\program>sdm changepassword "sdmhome=C:/usr/sap/JKS/JC00/SDM/program" "newpassword=abc123"

2)Changed the hash in the sdmrepository.sdc file & restarted J2EE server. Then used "sdm" as the password but still didn't help.

https://www.sdn.sap.com/sdn/collaboration.sdn?node=linkFnode6-1&contenttype=url&content=https://change-sdm-password

In both cases I get similar logs. Here is the log message in NW studio:

-


Apr 21, 2005 11:59:35 AM /userOut/deploy (com.sap.ide.eclipse.sdm.threading.DeployThreadManager) [Thread[Deploy Thread,5,main]] ERROR:

[001]Deployment aborted

Settings

SDM host : sapdemo

SDM port : 50118

URL to deploy : file:/C:/DOCUME1/sachin/LOCALS1/Temp/temp23444test1.ear

Result

=> deployment aborted : file:/C:/DOCUME1/sachin/LOCALS1/Temp/temp23444test1.ear

Aborted: development component 'test1'/'local'/'LOKAL'/'0.2005.04.21.11.58.42':

Caught exception while checking the login credentials for SAP J2EE Engine. Check whether the SAP J2EE Engine is up and running.

com.sap.engine.deploy.manager.DeployManagerException: ERROR: Cannot connect to Host: [sapdemo] with user name: [Administrator] Check your login information. Exception is: com.sap.engine.services.jndi.persistent.exceptions.NamingException: Exception while trying to get InitialContext. [Root exception is com.sap.engine.services.security.exceptions.BaseLoginException: User not authorized.]

(message ID: com.sap.sdm.serverext.servertype.inqmy.extern.EngineApplOnlineDeployerImpl.checkLoginCredentials.DMEXC)

Deployment exception : The deployment of at least one item aborted

-


Does SDM password has to match with any other password? Thanks

Sach