Skip to Content
author's profile photo Former Member
Former Member

"BOBJ" undefined error occurs, while Running Report

Hello Gurus,

I have a ASP.NET2.0 application, integrated with Crystal Reports 2008(SP3). And while running on my local DEV Unit, I get this following error: bobj undefined(as JavaScript Error).

All references taken care in web.config file and also Crystal ReportViewer.aspx.I made sure that CrystalReportViewer12 exists here:C:\inetpub\wwwroot\aspnet_client\system_web\2_0_50727\crystalreportviewers12, with all the files exits in the directory. And also a Virtual Directory created with crystalreportviewers12.

Details:

OS: Win 7 32bit

VS IDE: 2005

Add a comment
10|10000 characters needed characters exceeded

Related questions

5 Answers

  • Best Answer
    Posted on Dec 22, 2011 at 07:52 PM

    Please use the top right search box.

    [http://www.sdn.sap.com/irj/scn/advancedsearch?query=bobjisundefined|http://www.sdn.sap.com/irj/scn/advancedsearch?query=bobjisundefined]

    - Bhushan.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Dec 22, 2011 at 09:40 PM

    Where you make the fix re: crystalreportviewers12 directory will depend on how you are running your web site. There is the built in web server (Cassini) that can be used when you are running/testing your site from the local file system. Then there is IIS.

    When you work with the built in web server the crystalreportviewers12 is actually located here

    C:\Windows\Microsoft.NET\Framework\v2.0_50727\asp.netclientfiles\crystalreportviewers12 
      
    

    When working with IIS it is in the location you specified.

    C:\inetpub\wwwroot\aspnet_client\system_web\2_0_50727\crystalreportviewers12

    I often find it easier to use tools like Process Monitor to troubleshoot issues like this. You'll want to look for a file called crv.js in your logs. You'll likely see errors that it can't be found. It will tell you where your system is looking for the file. Copy the directory to the place your system wants it - then voila!

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 27, 2011 at 06:18 PM

    David,

    I think you were right on this, as my application may be looking at the wrong path for crv.js. I ran Process Monitor Tool(first time) and tried looking for crv.js and it couldn't find it anywhere. I would expect to be found here: C:\inetpub\wwwroot\aspnet_client\system_web\2_0_50727\crystalreportviewers12\js\crviewer\.

    I tried refresh the web page and recompiled it and still couldn't find.

    Note: I'm working on DEV Unit, IIS 7.0, VS 2..5, CR2008(runtime Installed).

    Any suggestions...

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 27, 2011 at 09:15 PM

    Bhushan,

    Thanks for your quick response. I hate to say, I tried all the Forums regarding on "Bobj" none of them seems to work. As per your KBase link provided earlier post,I tried changing my code to find the Crystal Report path( C:/inetpub/wwwroot/aspnet_client/system_web/2_0_50727/crystalreportviewers12) in my application, now it shows different error:

    Database logon failed.

    I already has Logon() function exists in my code, where it does get the Database Information.Since, my reports works fine with the older CR Version: 10.2.3600.0. I'm just testing to see whether my application works with newer CR 2008.

    Cases:

    1. 'BobJ' undefiened: Occurs only Reportviewer.aspx file has location:

    /aspnet_client/system_web/2_0_50727/crystalreportviewers12/css/default.css

    2. Database logon failed. : Only when I give full path to find the files.

    C:/inetpub/wwwroot/aspnet_client/system_web/2_0_50727/crystalreportviewers12/css/default.css

    I feel, like I'm the only one having this kind of issue.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 27, 2011 at 11:27 PM

    Finally, I got it working on my Win2008 Server.

    For some reason it doesn't work on my DEV Unit, but working on 2K8 Server(64-bit).Build an application with CR2008 assembly info, and deployed on server.

    That's it!

    Thanks to both David & Bhushan for all your time, helping me to troubleshoot the issue.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.