Skip to Content
author's profile photo Former Member
Former Member

Issue with Decimal Values in Bex Reporting

hello gurus,

I have extracted data from 2LIS_13_VDITM. In the ODS when I look at the Active data, column Billing Qty Sls Units - it shows "13,190 " and the Sales Unit is "KM".

ITEM SALES UNIT Billing Qty :Sales Unit

-


-


-


10 KM 13,190

20 KM 0,500

In R3 table VBRK also it stores in the above format.

But while reporting it rounds of the data as 13,000 and 1,000.

How can i get the actuals, in reporting also.

Pls advise. thanks in advance.

Add a comment
10|10000 characters needed characters exceeded

Related questions

6 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Apr 19, 2005 at 09:52 AM

    Hello Roberto. thanks for ur reply. cud u be more precise. i will tell u the settings in RSA1.

    in the additional properties tab of info object (0INV_QTY):

    Business Explorer

    -


    Decimal places - 0.000

    Display - Not defined

    Bex Description - Short Descp

    Miscellaneous

    -


    Key Figures with Max Precision - (checkbox is unchecked)

    Attribute Only -(checkbox is unchecked)

    Now i just checked Key Figures with Max Precision and activated the infoobject. executed the report again. it still shows the same output. Do I need to extract data again.

    rgds

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Apr 19, 2005 at 11:39 AM

    Hi Eugene -Scaling it to 1 did not help.

    Hi Roberto -> I had a look at the entries in T006 for KM (kilometers)and M(meters). this is what i got.

    [Int. meas. unit] [Decimal.pl.rnd.] [Decimal places]

    -


    -


    -


    KM | 0 | 0

    M | 2 | 0

    And in SPRO in Src System and BW Sytem there is no mention of KM and meters.

    Message was edited by: bw

    Message was edited by: bw

    Message was edited by: bw

    Add a comment
    10|10000 characters needed characters exceeded

    • bw,

      Have you tried what Somnath said?

      In the screen according to Somnath path (or tcode CUNI) in the field for input using drop-down menu choose 'Length'. Then click on Units of measure button. In a new screen scroll up (if needed). Find 'KM' and do what Somnath recommended.

      Best regards,

      Eugene

  • author's profile photo Former Member
    Former Member
    Posted on Apr 19, 2005 at 09:35 AM

    Take a look to the property of your KF in BEx and in RSA1 (in other properties there is checkbox...)

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Apr 19, 2005 at 10:21 AM

    hi Eugene,

    i even checked the properties in bex query analyzer.

    Constant Selection - no check

    Scaling Factor - Nothing Defined

    no of decimal places - 0.000

    calculate result as - nothing defined

    calculate single values as - nothing defined

    is there anything wrong in the above settings.

    thanks

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Apr 19, 2005 at 11:33 AM

    Hi,

    In the BW system, goto SPRO -> SAP NetWeaver (if 3.5) -> General Settings -> Check Units of Measurement -> Units of Measurement -> Choose the unit corresponding to 'KM' -> Click on 'Details' button in the toolbar.

    Look the field 'Decimal Pl rounding'. Change this to 3 or whatever value you choose and see if it works.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Apr 19, 2005 at 12:34 PM

    Hello Roberto ,Eugene ,Somnath.

    thanks a Ton. my issue is solved. all of u were right.

    the reason i cud not find KM was b'cas i did not select Length in my Dimensions.

    Now it is coming all right. Thanks Again

    Points to all...

    best regards,

    TR PRADEEP

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.