Skip to Content

How to display seconds in timestamp format hh:mm:ss as measure in Design Studio Application

Hello,

We have a requirement to show Average Wait Time for answered calls for each time interval for a our Call Center. We are adding this measure in our Design Studio Dashboard application. Avg Wait time is a calculated field where the result is in seconds, we were able to convert this already to hh:mm:ss format (concat) in the universe level and set this as a measure. When we bring this measure in to our DS application, value is 0. We need to show this as a measure to line up with rest of our measures; Incoming Calls, Answered, etc. How can we keep this as a measure with the hh:mm:ss format?

Thank you in advance for any help and suggestions.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Dec 21, 2016 at 11:21 PM

    Hi Tammy,

    Yes, the value shows the correct format in WEBI. Seems like Design Studio doesn't like the hh:mm:ss format as a measure. When we keep it as a dimension, it will show in DS application with the correct hh:mm:ss format but we can only insert it as a row and not a column, where the other measures are. Attached is a screen capture of our goal, to show the Avg Wait Time for the time interval in the bubble.

    Thanks!

    Add comment
    10|10000 characters needed characters exceeded

  • Dec 21, 2016 at 11:26 PM
    Add comment
    10|10000 characters needed characters exceeded

  • Dec 22, 2016 at 05:32 PM

    Thanks Tammy. I'll go through the thread.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jan 24 at 12:20 PM

    Hello,

    I'm running into similar issue, "hh:mm:ss" values (gotten from BEx Query formula with TIME function) are displayed correctly in a CrossTab component in DesignStudio but in InfoChart they are shown all as 0 ...

    So it seems this bug hasn't been fixed yet even though it's been around for over 2 years !? Yet all i can find on this is this old thread... with unfortunately no workaround :)

    Add comment
    10|10000 characters needed characters exceeded