Skip to Content
Former Member
Dec 13, 2011 at 08:53 PM

Wierd issues in UWL when used with Light Desktop



I have set up a UWL iView within a light desktop (with a light framework page). When I launch any workitem, I 'sometimes' encounter an error - System Alias is not defined or permission denied for this user. I ran the trace for the request and found that the UWL 'sometimes' calls the following as one of the URL parameters -" &System=ECC_ED1' title='UWL - Launch SAP Transaction" and thus is unable to recognize the system object as it reads the entire string as the system alias. The error log is as follows

com.sapportals.portal.appintegrator.ApplicationIntegratorException: Unknown system alias.

System Alias: 'ECC_ED1' title='UWL - Launch SAP Transaction',


Reason: System Alias is not defined or permission denied for this user

The wierd part is that sometimes it just works fine without me having to do anything and once I get it working I do not encounter the error again. Also, the config works with no issues if I have everything on the Default Desktop instead of the light desktop. I am on Portal 7.3. I just wanted to know if anyone has experienced this issue before and if yes, is there a solution. I have tried searching for notes on this issue but didn't come across a relevant one yet (Read the following - 853509, 877188).