Skip to Content
author's profile photo Former Member
Former Member

Nakisa OrgChart 3.2 not saving / publishing / not doing ANYTHING

Hi,

When we deploy the latest OrgChart version (provided by SAP a week ago), we are unable to save / publish or enter a sap connection string (pretty much all the functions are having the same issue!....it just sits there and does nothing!).

We had this issue with first 3.2 build for OrgChart also.

The cds.log contains the following:

13 Dec 2011 12:38:53 ERROR com.nakisa.Logger - ApplicationSettings : SettingsResources.xml file not found at /usr/sap/DM8/J00/j2ee/cluster/apps/Nakisa/OrgChart/servlet_jsp/OrgChart/root//XML/SettingsResources

It's my understanding that there is no longer a SettingsResources.xml file (now a SettingsResources directory with .txt files in ??), so why is Nakisa even trying to reference the this file?

We are using CE 7.2 SP1 on RHEL 5.6

Thanks in advance!

Neil

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

6 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Dec 15, 2011 at 01:31 PM

    Hi again,

    We found this in the admin guide :

    "Read-only access is configured for remote support of Nakisa applications. The following

    actions are disabled in the Nakisa AdminConsole when a read-only user logs in:

    Submit in all setup wizards

    Save As, Save, and Publish build

    Create new admin user

    Change admin password"

    This is exactly how our system is behaving. I might add that we are unable to enter data conections via the Data Center and nothing is working properly in the Application-wide settings. Examples Log Viewer / Add-On Manager not working.

    But we are the 'Admin' user and we've not got as far as to change anything to 'read-only' as it won't allow us.

    If this is the source of our woes, does anyone know how to overcome this issue?

    Regards

    Neil

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Dec 13, 2011 at 06:46 PM

    Did yu undeploy before deploying? If not, please do.

    By 3.2 do you mean 3.0 SP2?

    Which build number is this?

    FYI the latest build I deployed was 0702024600 on a NW 7.3 platform which worked without issue.

    Stephen

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Dec 13, 2011 at 08:06 PM

    Hi Neil,

    The SettingsResources issue is a dummy issue so please ignore it.

    I also deployed build 246 recently at a client and had no issues. It could be something environmental like your browser version or Java version. What version of IE are you using and are any settings restricted by company policy?

    Best regards,

    Luke

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 14, 2011 at 08:56 AM

    Hi Luke / Stephen,

    Thanks for your responses!

    I have undeployed and deployed (SAP and Nakisa have said that this is a deployment issue (but, I think that is because we have exhausted all avenues!), but everytime I've deployed the .SCA it has done it without any issues / errors). Nakisa also asked us to try deploying via the NWDS (initially done via the JSPM), and we got the same problems.

    We are using Build - 0702024600 for Nakisa

    IE Explorer is 8.0.7

    Firefox (same problems) 8.0.1

    java version "1.5.0_09"

    Regards

    Neil

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 14, 2011 at 09:02 AM

    also guys, are you using Redhat or SuSE?...I'm just wondering if SuSE might be less problematic.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 14, 2011 at 02:15 PM

    Hi again,

    Updated java to 6, but still getting the same issue!...it's as if the Database is in 'read-only' mode!

    Have you ever seen this type of issue before, where you click on buttons in Nakisa and it just refreshes, rather than

    do what you want it to?

    Regards

    Neil

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.