Skip to Content
author's profile photo Former Member
Former Member

Create batch input, does not include all records

Have anyone experienced, when doing Create Batch Input from the LSMW menu it does not include all rows.

For example I have a .txt file with 3000 records that I specify in "Specify Files"

"Read Data" reads 3000 records.

"Convert Data" Converts 3000 records

"Create Batch input Sessions" creates 2461 records? ?

I have noticed that this happen when the system is busy running many batches and Idocs.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

4 Answers

  • Best Answer
    Posted on Dec 13, 2011 at 04:32 PM

    I have never see such an issue in all the years I am working with LSMW (and 3000 records is a small number in my environment)

    Are you sure you dont mix records with transactions?

    the read step counts records.

    the conversion step shows number of records read, number of records written, number of transactions written

    the step create batch input shows the number of transactions copied into the BI session.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 15, 2011 at 01:37 AM

    Hi ,

    which LSMW object you are talking abt ,it totally depends how you created the batch input session.....

    for exp...im loading condition records ...in the LSMW direct program.(RV14BTCI).. i have following options...

    Max no records per transaction
    Max. no. cond. recs per screen
    Max no. scales per screen
    Max. no. cond. recs in table
    

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 15, 2011 at 06:13 AM

    Hi Dmoney,

    sometimes there is issue that there are let's say 3000 records in read Data step but when they are converted there might be 2461 records or less.But this happens when we have put some validations in LSMW for a particular condition and used either SKIP_TRANSACTIOn or SKIP_RECORD in step 5 " Mapping and conversion Rules of LSMW.

    I am not able to understand as to why till converted data it is coming fine.

    If at all there are any validations it should have been filtered out at convert Data step only.

    Experts,Please correct if i am wrong anywhere.

    Regards,

    Rahul

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 15, 2011 at 09:43 AM

    I'm talking about LSMW programs with regular Batch input Recording.

    I haven't noticed which transactions it skips since I do not run the Batch, when I notice that it does not include all rows as I have read and converted.

    However usually if I "Create the batch input session" once again it includes all the records from the conversion before.

    But since Create a batch input can take a long time depending on the amount of transactions it creates this is not a desired option.

    So it is not possible that the transactions it does not create are errors since its possible to run them successfully. And I haven't used any SKIP TRANSACTION in the mapping step.

    But like I said this only happens when the system is running many batches / idocs at the moment, for example if we are loading the material master at the same time as I run my batch input programs.

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      So, have you gone to SM35 to see if there were errors?

      When you run multiple batches in parallel, there can be locking issues that don't appear when the transactions are run sequentially, one at a time. And the error sessions can then be successfully processed.

      Rob

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.