Skip to Content
author's profile photo Former Member
Former Member

Unable to interpret 1,000.000 as a number while posting IDOCs

Hi All,

I know this query has been asked multiple times but as of now I am unable to find the right match so posting this query again. We are posting an IDOC from SAP PI to SAP ECC using SAP PI IDOC Adapter. When the IDOC is sent there is one specific value in one of the fields which have value 1000.00. Now when the IDOC is received by SAP the value is received as 1,000.000. As far as I understand this is because the user configured in the RFC destination in SAP PI (which sends the IDOC to SAP) is having in its default profile the Decimal Notation as 1,234,567.89 and hence we see the value as 1,000.00.

But then the IDOC is not posted in SAP and the issue is: "Immediately processing not possible: Unable to interpret 1,000.000 as a number".

As I am not much aware about ABAP being a PI consultant, would appreciate if experts can guide me on how to resolve this issue. Thanks for taking time to read through the issue.

Thanks,

Pratik

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Dec 09, 2011 at 10:42 AM

    Please check at abap end for the inbound parameters.

    In we20 the message type will be assigned .Double click it and you will get the process code.Double click that and you will get the required FM.

    If the inbound function module is Z ,Please do the necessary change.

    OR

    Else try WE19 to process the idoc (Existing).

    Execute and then check the Inbound function module option and then call in debugging mode to check the where the error is happening.

    Hope it helps.

    Thanks!

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 09, 2011 at 12:52 PM

    You have two obvious choices ( and perhaps others). 1,000.00 is not a number...it's an alphanumeric value, and is therefore a type 'C' value.

    So, you can have the sender change the file to send the file as alphanumeric values (needs to be 1000.000) or you can add exit or badi to "strip" the comma(s) and any other punctuation or currency symbols, something like:

    replace all occurrences of ',' with ' ' into <yourfieldname>.

    condense <yourfieldname> no-gaps.

    There are other solutions....

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.