Skip to Content
author's profile photo Former Member
Former Member

Invoice Plan Run T.code MRIS : Message getting - No documents selected

Dear All Experts,

Very Good Morning !

I am configuring Invoice Plan for my periodic invoicing requirement, While I am referring this these threads found on our forum SDN.

1 ) [Invoice Plan|Invoicing plan; - Post

2 ) [Invoice Plan in SAP|http://wiki.sdn.sap.com/wiki/display/HOME/InvoicingPlanin+SAP] - Wiki

I am following as per the experts replies mention in it and finally running MRIS for the same, I am getting below message after execution :

No documents selected

Message no. M8702

Diagnosis

There are no documents that comply with your selection criteria.

Procedure

You can enter new selection criteria or exit processing.

Steps I produce for this scenario :

For PO :

1 ) Selected FO in ME21N / Enterted validity period in time frames 01.11.2011 to 30.12.2012 ( DD.MM.YYYY)

3 ) Created account assignment PO with K, Tax code V0 entered.

4 ) Item Details - Invoice Tab : Inv. Receipt - TICKED. ERS - TICKED.

5 ) Item Details - Delivery Tab : Goods Receipt - TICKED GR Non - Valuated - TICKED

6 ) Item Details - Invoice Tab : Invoice Plan is selected - 10 ( Standard SAP )

For Vendor Master : XK02

1 ) GR Based Inv Verification - Not Ticked.

2 ) AutoEvalGRSetmt. Del - TICKED

3 ) AutoEvalGRSetmt. Rel - TICKED

After all this running MRIS I am getting message " No documents selected ".

Apart all these settings have I missed anything here to configure ?

Experts guidance / inputs / comments will be very helpful.

Regards,

Revati Joshi.

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Dec 09, 2011 at 06:22 AM

    Hi

    Message setting is not done properly.

    GO to transaction code NACE, choose proper program and change , maintain default condition record .

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Dear redriver,

      Excellent answer. Probelm solved and your all commnets worked just exceptionally perfect ! 100 Points !

      I am thankfull to redriver, Sudhansu, Venkat who all contributed to this thread and helped me alot to solve this problem.

      Regards,

      Revati Joshi.

  • author's profile photo Former Member
    Former Member
    Posted on Dec 09, 2011 at 05:54 AM

    Enable the GR Based Inv Verification tab in vendor master.

    In invocie tab enable ERS check box.

    The report gives the pending invoices as per the invoice plan.If they are no invoices then the report give no documents.

    Even if MIRO is done then also it will give the same result as there are no pending invoices.

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Dear Venkat,

      Thank you for quick rsponse.

      I have already enabled all you said, still did fresh changes. And again running MRIS with Test Run Ticked still I am getting same result. No documents selected.

      I tried with unticking Test Run as well, not changes yet in result. No Luck.

      Any other check point where I should focus, or missed else ?

      Experts guidance will be helpfull.

      Regards,

      Revati Joshi.

  • author's profile photo Former Member
    Former Member
    Posted on Dec 09, 2011 at 06:15 AM

    Hi,

    Have you maintained the Out Put condition record in NACE for invoicing plan ?

    Please maintain and then check again

    NACE- >MR(invoice verification) -> INS -> here maintain the condition record for company code

    Then try again

    Edited by: redriver on Dec 9, 2011 7:20 AM

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.