Skip to Content

Handling multiple subtypes creation/update

Hi,

I have the following request: to update subtype 2 or 6 of the infotype 965.I am not able to create a correct generic service update, as there is no support function for updating this infotype correctly (they do in the backend several checks and filling of fields based on customizing) so I would have to copy pieces from standard code, which I am not sure will produce an accurate result.

The option is to use SAP_PA service and add subtype 2 and 6 operations. I have added the following:

3 0965 2 Change Without delimiting

4 0965 6 Change without delimiting

I use a generic service in order to be able to default the values and to choose which of the subtype should be used.

I have added a dummy rule on both operations, asking if BEGDA = u201931.12.9999u2019 (value set manually by me in the custom generic service) so that I can distinguish which subtype I want to update.

The workflow says processed but there is no update in the database.

Tried several tricks to make available only one subtype operation, but for now no full success.

Strange enough, if I send both lines with subtype 6, it gets updated, but this does not happen if I send both with infotype 2.

I have tried also to enter a combination like:

0965 * * Change Without Delimiting

But it does not work at creation of new lines, even after customizing V_5ASRFSCNPAPRP.

This gives a dump telling subtype * is not allowed (infotype has time constraint T).

Any idea on what is the general approach/strategy when trying to achieve multiple subtype updates/creation?

When testing only with one subtype it is all fine, of course.

Thank you again for your input, much appreciated.

Ana-Maria

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Best Answer
    Posted on Dec 08, 2011 at 05:29 PM

    For multiple records handling please refer to note 1043692 and

    configure the process according to your needs.

    (Refer sections: I. A) 1) & B) ]

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Ana-Maria TARCA

      Dear Ana-Maria,

      Infotype 0965 has no subtypes defined in standard. Hence the error that is being triggered is correct. This error is coming from new infotype framework. Have you enhanced the standard infotype 0965? What are the steps that you have followed to enhance this infotype? It could be possible that you have missed any steps because of which the error message is being triggered from the new infotype framework.

      Regards,

      Roy

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.