Skip to Content

Enterprise XI 3.1 trusted authentication problems

I followed the instructions to enable trusted authentication (XI 3.1 admin guide, page 561+):

  • created shared secret value in CMC ('my_secret'); checked 'trusted authentication is enabled; set secret validity period to 1; left tmeout at 0

  • created the TrustedPrinicpal.conf file in C:\Program Files\Business Objects\BusinessObjects Enterprise 12.0\win32_x86

  • added line to file that reads SharedSecret=my_secret; saved file

  • edited InfoView's web.xml file located at C:\Program Files\Business Objects\BusinessObjects Enterprise 12.0\warfiles\WebApps\InfoViewApp\WEB-INF

  • made the following changes:

<context-param>

<param-name>siteminder.enabled</param-name>

<!-- <param-value>true</param-value> -->

<param-value>false</param-value>

</context-param>

<context-param>

<param-name>sso.enabled</param-name>

<!-- <param-value>false</param-value> -->

<param-value>true</param-value>

</context-param>

<context-param>

<param-name>trusted.auth.user.retrieval</param-name>

<param-value>QUERY_STRING</param-value>

</context-param>

<context-param>

<param-name>trusted.auth.user.param</param-name>

<param-value>user_name</param-value>

</context-param>

  • restarted tomcat and server intelligence agent (probably not necessary, but did it just for good measure)

  • attempted to logon to InfoView: http://localhost:8080/InfoViewApp/logon/start.do?user_name=foobar

didn't get an error message, but it didn't get past the logon page.

What did I miss?

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Dec 07, 2011 at 10:11 PM

    Hi,

    It looks like all the configuration has been done correctly, But request you to Please check the web.xml again for the below changes

    <context-param>

    <param-name>vintela.enabled</param-name>

    <param-value>false</param-value>

    Also use the below url and test the issue again

    http://servername:port/InfoViewApp/logon/logon.do?user=Administrator

    Also we have very good kb article on the complete configuration.Please refer the below article for further details.

    1422248 - Setting up Trusted Authentication in XI 3.x for Infoview and Opendocument using QUERY_STRING

    Regards,

    Raja

    Add a comment
    10|10000 characters needed characters exceeded

    • That worked. http://localhost:8080/InfoViewApp/logon/logon.do?user_name=[user name here]

      http://localhost:8080/InfoViewApp/logon.jsp?user_name=[user name here] did NOT work. It gives an error message about the account being disabled (which it is not).

      Looks like the administrator's guide needs a SERIOUS revision. While you (SAP) are at it, include the proper URL that will 'see' the querystring parameter.

      Thanks for your help.

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.