Skip to Content
author's profile photo Former Member
Former Member

Settlement Rule creation in Maitenance order

Hello Experts,

I'm done bashing my head on the keyboard to try figure this out, so I'm reaching out to you all.

In a technical object there is the ability to maintain a cost center and a settlement order. When this technical object is used in a maintenance order, if a cost center is maintain it automatically creates a settlement rule. However if a settlement order is maintained, the settlement rule in the order is not created. Is there a way, or a setting in the settlement profile or a setting somewhere to say ...

if a cost center is maintained in the tech object create the settlement rule in the order based on CTR. If no cost center is maintained in the tech object, create the settlement rule in the order based on ORD and automatically carry in the settlement order number. and then of course of neither CTR or ORD are maintained in the tech object, do as we currently set up and force the user to maintain a rule manually upon release of the order.

I've looked at the USER Exit IW010027, however we can find where this is used. We have set a breakpoint and it still doesn't seem to be calling the function module included in the exit, when we create and release a work order.

Any help at all would be appreciated.

Thanks

Lisa

Add a comment
10|10000 characters needed characters exceeded

Related questions

6 Answers

  • Posted on Dec 08, 2011 at 08:24 AM

    In your settlement profile 40 if default ORD is maintained

    and

    in your technical object Standing order is maintained

    then automatically settlement rule will be created for Standing Order only and not to the settlement rule maintained in the standing order

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Dec 08, 2011 at 08:25 AM

    Hi Lisa,

    User-exit IWO10027 is the correct one.

    Did you activate the user-exit in TCode CMOD?

    PeteA

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 08, 2011 at 06:46 PM

    thanks for your answers

    Yes, we have activated the project in CMOD, and then set the breakpoint on the function module as well as in the IW31 and its still not hitting it when we create a work order and release.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Dec 09, 2011 at 04:59 PM

    Hi,

    Did you try to release the work order?

    Regards

    Carlos

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 09, 2011 at 05:02 PM

    Yep, work order has been released.

    Everything is activated, and release and should work. But doesn't. It doesnt' call the function module in the user exit.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Dec 09, 2011 at 06:58 PM

    Maybe your developer can debug the program and catch the problem

    Regards

    Carlos

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.