Skip to Content
author's profile photo Former Member
Former Member

SAP spool system issues

Dear Experts,

We have a peculiar issue with SAP Spool system. Here I am going to explain the scenario of our Production system and the issue we are facing.

In our production system we have one Central Instance and Five dialogue instances and each instance installed on separate servers of AIX.

We have created an output device with host spool access method as 'S'(Print using SAP Protocol) and had given one APP1(Dialogue instance 1) as host spool server. We have maintained IP address and host name of printer, in the hosts file of the APP1 server. We have tested the printer connection from SAP and it had worked.

When users give any print request, that request was being processed by spool server and it gets held-up in the spool and resulting in error.

Request is being processed by SAP but not sent to printer. This we have resolved by adding the IP address and hostname of the printer in hosts file of all instances of the production system.

We are unable to sort out why the spool system is working like this. As per SAP Print architecture when a print request is generated, that request is directed to the spool server and from there it is sent to the printer. As per our understanding it would be enough to maintain data in hosts file of the spool server only.( In this case APP1).

But the spool system is not working in that way. Could you please clarify on this.

Thanks & Regards,

Manoj Kumar S

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Posted on Dec 09, 2011 at 01:37 AM

    Hello

    in regard to your printing from multiple app servers, when a print is executed on a appserver it verifies a connection to the printer? hence this could be happening before passing on the spool server ?

    Arun

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Dec 09, 2011 at 04:32 PM
    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      If the status of a spool request has been set to Compl. or Problem but no output is printed, then:

      The SAP spool system finished processing the spool request and is working normally

      A problem with the data in the spool request, with the printer definition in the SAP System, or with the host system spool or printer prevented any output from appearing. You can log output data to help you analyze the problem. For information about activating this logging, see Logging Print Output Data.

      Regards

      Hussain

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.