Skip to Content

Performance since IDM 7.1 SP6

Hello,

since SP6 we have an performance problem in the UI of the IDM system.

When i search for a person with Name* or *Name the performance ist ok - but when i search

with two wildcards like 'name' then the performance is very bad!

We are using oracle as database.

best regards

Thomas

Edited by: Thomas Berger on Dec 6, 2011 12:46 PM

Edited by: Thomas Berger on Dec 6, 2011 12:46 PM

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Dec 07, 2011 at 11:11 AM

    Hi Thomas,

    do you update the statistics regularly?

    Can you tell us the performance using the extended search?

    using the standard search, the Database searches in all attributes for your string.

    Using the extended search, the Database searches only within the special attribute you put in the search string.

    Never the less, using "Name" as searchstring is easier to find then using "name*", because the database have to compare the hole string, and not only the beginning or the end.

    Kind regards,

    Achim Heinekamp

    Add a comment
    10|10000 characters needed characters exceeded

    • hello archim,

      today i found this new note on the marketplace

      -


      Note 1658351 - Bad performance in the Identity Management User Interface

      Symptom

      You experience bad performance when executing searches in the Identity Management User Interface. There may also be a high number of deadlocks in the database. Searches that worked properly (fast) suddenly start to perform extremely slow (range 30s ++).

      The execution plans that are generated by the database are reused - even when it is not optimal for the current search. This may result in slow execution of some searches.

      Other terms

      Identity Management, ID Mgmt, IdM

      Reason and Prerequisites

      You are using SAP NetWeaver Identity Management 7.1 SP6 or SAP NetWeaver Identity Management 7.2 SP3.

      Solution

      Apply the attached patch for the follwing versions:

      SAP NetWeaver Identity Management 7.1 SP6 User Interface

      SAP NetWeaver Identity Management 7.2 SP3 User Interface

      -


      At the moment the Patch for the SP6 is not released - but i think this is the solution for my problem because we are using

      SP6 since one month - and after we applied SP6 we become this problems!

      I will update this thread until i got the Patch for the SP6.

      Thomas

  • Posted on Dec 15, 2011 at 09:08 AM

    Note 1658351 was the solution for our problem

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.