Skip to Content

Problem with Horizontal Scroll in Table

Hi,

I've a fixed number columns in my table. I'm hiding a couple of columns based on some business logic.

It is being done by using the 'Visible' property of the context itself. Also, scrollable column count has been set to 5 to display horizontal scroll bar.

Initially, the table is displayed properly without any issues and displays only those columns, which are being set visble.

But, when I keep scrolling the horizontal scroll on the browser; after sometime it starts displaying all the columns. I'm not using the any scroll event to hide the fields. I'm doing it 'On Action' of a button to display data.

I'm using IE 6.0. Please let me know in case anybody has faced a similar kind of issue and resolved it. Also, let me know in case any additional details are required.

Regards,

Satyajit

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • Posted on Dec 06, 2011 at 01:04 PM

    Experts... any thoughts on this?

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 06, 2011 at 02:43 PM

    Hi,

    Create One more attribute in the table context with type WDY_BOOLEAN. bind this new attribute to the corresponding enabled property of the table field and try.

    Thanks,

    Shailaja Ainala.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Dec 08, 2011 at 08:49 AM

    First thing is that. How did you set the visible columns for scroll count. Is it done through the context attribute binding and providing the value at runtime. Is that So.

    When you scroll the table, MODIFYVIEW gets triggered. Can you check wether ONSCROLL is there any event for the Table. If yes, reset the scroll count to 5 as per your requirement.

    Add a comment
    10|10000 characters needed characters exceeded

    • @Lekha-the scroll count has been hardcoded to 5 in the table properties.

      We found a solution to this. It's somehow related to the row selection. The issue was resolved, when selectionmode property of the table was set to 'None', restricting any row selection.

      Not sure of the real issue though...may be some UI related problem...

      Keeping the thread open for any ideas/suggestions on this....

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.